summaryrefslogtreecommitdiffstats
path: root/src/backend/utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/backend/utils/Makefile')
-rw-r--r--src/backend/utils/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/backend/utils/Makefile b/src/backend/utils/Makefile
index deb9016..4299735 100644
--- a/src/backend/utils/Makefile
+++ b/src/backend/utils/Makefile
@@ -38,9 +38,12 @@ all: distprep probes.h generated-header-symlinks
distprep: fmgr-stamp errcodes.h
-.PHONY: generated-header-symlinks
+.PHONY: generated-header-symlinks submake-adt-headers
-generated-header-symlinks: $(top_builddir)/src/include/utils/header-stamp $(top_builddir)/src/include/utils/probes.h
+generated-header-symlinks: $(top_builddir)/src/include/utils/header-stamp $(top_builddir)/src/include/utils/probes.h submake-adt-headers
+
+submake-adt-headers:
+ $(MAKE) -C adt jsonpath_gram.h
$(SUBDIRS:%=%-recursive): fmgr-stamp errcodes.h