summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.darwin
diff options
context:
space:
mode:
Diffstat (limited to 'src/makefiles/Makefile.darwin')
-rw-r--r--src/makefiles/Makefile.darwin12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.darwin b/src/makefiles/Makefile.darwin
new file mode 100644
index 0000000..7095f66
--- /dev/null
+++ b/src/makefiles/Makefile.darwin
@@ -0,0 +1,12 @@
+# env var name to use in place of LD_LIBRARY_PATH
+ld_library_path_var = DYLD_LIBRARY_PATH
+
+ifdef PGXS
+ BE_DLLLIBS = -bundle_loader $(bindir)/postgres
+else
+ BE_DLLLIBS = -bundle_loader $(top_builddir)/src/backend/postgres
+endif
+
+# Rule for building a shared library from a single .o file
+%$(DLSUFFIX): %.o
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -bundle $(BE_DLLLIBS) -o $@