summaryrefslogtreecommitdiffstats
path: root/src/test/subscription/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/subscription/meson.build')
-rw-r--r--src/test/subscription/meson.build46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/test/subscription/meson.build b/src/test/subscription/meson.build
new file mode 100644
index 0000000..bd673a9
--- /dev/null
+++ b/src/test/subscription/meson.build
@@ -0,0 +1,46 @@
+# Copyright (c) 2022-2023, PostgreSQL Global Development Group
+
+tests += {
+ 'name': 'subscription',
+ 'sd': meson.current_source_dir(),
+ 'bd': meson.current_build_dir(),
+ 'tap': {
+ 'env': {'with_icu': icu.found() ? 'yes' : 'no'},
+ 'tests': [
+ 't/001_rep_changes.pl',
+ 't/002_types.pl',
+ 't/003_constraints.pl',
+ 't/004_sync.pl',
+ 't/005_encoding.pl',
+ 't/006_rewrite.pl',
+ 't/007_ddl.pl',
+ 't/008_diff_schema.pl',
+ 't/009_matviews.pl',
+ 't/010_truncate.pl',
+ 't/011_generated.pl',
+ 't/012_collation.pl',
+ 't/013_partition.pl',
+ 't/014_binary.pl',
+ 't/015_stream.pl',
+ 't/016_stream_subxact.pl',
+ 't/017_stream_ddl.pl',
+ 't/018_stream_subxact_abort.pl',
+ 't/019_stream_subxact_ddl_abort.pl',
+ 't/020_messages.pl',
+ 't/021_twophase.pl',
+ 't/022_twophase_cascade.pl',
+ 't/023_twophase_stream.pl',
+ 't/024_add_drop_pub.pl',
+ 't/025_rep_changes_for_schema.pl',
+ 't/026_stats.pl',
+ 't/027_nosuperuser.pl',
+ 't/028_row_filter.pl',
+ 't/029_on_error.pl',
+ 't/030_origin.pl',
+ 't/031_column_list.pl',
+ 't/032_subscribe_use_index.pl',
+ 't/033_run_as_table_owner.pl',
+ 't/100_bugs.pl',
+ ],
+ },
+}