summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 07:54:12 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-26 07:54:12 +0000
commit1a97e22260f0be66eb46829fc6ee255cbf200bd4 (patch)
treeaaa2fe8bb43d66517b374fb11d874b04211e4afd
parentReleasing progress-linux version 260-0.0~progress7.99u1. (diff)
downloadpostgresql-common-1a97e22260f0be66eb46829fc6ee255cbf200bd4.tar.xz
postgresql-common-1a97e22260f0be66eb46829fc6ee255cbf200bd4.zip
Merging upstream version 261.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xpg_createcluster5
-rw-r--r--server/postgresql.mk2
-rw-r--r--t/045_backup.t2
3 files changed, 5 insertions, 4 deletions
diff --git a/pg_createcluster b/pg_createcluster
index 66f0b82..70d839e 100755
--- a/pg_createcluster
+++ b/pg_createcluster
@@ -4,7 +4,7 @@
# the postgresql-common infrastructure.
#
# (C) 2005-2013 Martin Pitt <mpitt@debian.org>
-# (C) 2012-2021 Christoph Berg <myon@debian.org>
+# (C) 2012-2024 Christoph Berg <myon@debian.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -20,7 +20,7 @@ use strict;
use warnings;
use PgCommon;
use Getopt::Long;
-use POSIX qw/lchown setlocale LC_ALL LC_CTYPE/;
+use POSIX qw/lchown setlocale LC_ALL LC_NUMERIC/;
$ENV{'PATH'} = '/sbin:/bin:/usr/sbin:/usr/bin'; # untaint
@@ -218,6 +218,7 @@ unless (setlocale (LC_ALL, "")) {
grep { /^(LC_|LANG)/ } sort keys %ENV;
error ("The locale requested by the environment is invalid:\n$env")
}
+setlocale (LC_NUMERIC, "C"); # otherwise version comparisons break
if (@ARGV < 2) {
print "Usage: $0 [options] <version> <cluster name> [-- <initdb options>]
diff --git a/server/postgresql.mk b/server/postgresql.mk
index 8e73f66..64768be 100644
--- a/server/postgresql.mk
+++ b/server/postgresql.mk
@@ -52,7 +52,6 @@ CONFIGURE_FLAGS = \
--enable-nls \
--enable-thread-safety \
--enable-debug \
- --enable-dtrace \
--disable-rpath \
--with-uuid=e2fs \
--with-gnu-ld \
@@ -132,6 +131,7 @@ endif
ifeq ($(DEB_HOST_ARCH_OS),linux)
CONFIGURE_FLAGS += --with-systemd
CONFIGURE_FLAGS += --with-selinux
+ CONFIGURE_FLAGS += --enable-dtrace
endif
ifneq ($(filter pkg.postgresql.cassert,$(DEB_BUILD_PROFILES)),)
diff --git a/t/045_backup.t b/t/045_backup.t
index 1a47c27..88638bc 100644
--- a/t/045_backup.t
+++ b/t/045_backup.t
@@ -95,7 +95,7 @@ foreach my $v (@MAJORS) {
}
}
if ($systemd) {
- program_ok $pg_uid, "psql -c 'alter system set checkpoint_timeout=30'"; # minimum
+ program_ok $pg_uid, "psql -c 'alter system set checkpoint_timeout=30'" if ($v >= 9.4); # 30s is minimum
program_ok $pg_uid, "psql -c 'select pg_reload_conf()'";
program_ok 0, "systemctl start pg_basebackup\@$v-main";
} else {