summaryrefslogtreecommitdiffstats
path: root/dh_make_pgxs/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:35:12 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:35:12 +0000
commit53b8d04ebc10d070b7efafd6dfa9de2897916888 (patch)
treee95cc322bcaf0990808f10f0fdcb508014e7e496 /dh_make_pgxs/debian/rules
parentInitial commit. (diff)
downloadpostgresql-common-53b8d04ebc10d070b7efafd6dfa9de2897916888.tar.xz
postgresql-common-53b8d04ebc10d070b7efafd6dfa9de2897916888.zip
Adding upstream version 258.upstream/258
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dh_make_pgxs/debian/rules')
-rwxr-xr-xdh_make_pgxs/debian/rules36
1 files changed, 36 insertions, 0 deletions
diff --git a/dh_make_pgxs/debian/rules b/dh_make_pgxs/debian/rules
new file mode 100755
index 0000000..5c0ff40
--- /dev/null
+++ b/dh_make_pgxs/debian/rules
@@ -0,0 +1,36 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with pgxs
+
+override_dh_installdocs:
+ dh_installdocs --all README.*
+
+# if the package does not support building from subdirectories, use
+# `--with pgxs_loop` above.
+#
+# change the way tests are run:
+# override_dh_pgxs_test:
+# +pg_buildext installcheck . . postgresql-%v-@EXTNAME@
+
+# classic `pg_buildext` interface:
+
+#include /usr/share/postgresql-common/pgxs_debian_control.mk
+#
+#override_dh_auto_build:
+# +pg_buildext build build-%v
+#
+#override_dh_auto_test:
+# # nothing to do here, see debian/tests/* instead
+#
+#override_dh_auto_install:
+# +pg_buildext install build-%v postgresql-%v-@EXTNAME@
+#
+#override_dh_installdocs:
+# dh_installdocs --all README.*
+#
+#override_dh_auto_clean:
+# +pg_buildext clean build-%v
+#
+#%:
+# dh $@