summaryrefslogtreecommitdiffstats
path: root/man-po/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 13:17:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 13:17:26 +0000
commita4dc4fbcc1b131061dcccd5cdcc2395d9a2ba784 (patch)
treebc531e7e083fff1668bb4e79e9692d8cc47aea95 /man-po/Makefile.am
parentInitial commit. (diff)
downloadpsmisc-a4dc4fbcc1b131061dcccd5cdcc2395d9a2ba784.tar.xz
psmisc-a4dc4fbcc1b131061dcccd5cdcc2395d9a2ba784.zip
Adding upstream version 23.7.upstream/23.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man-po/Makefile.am')
-rw-r--r--man-po/Makefile.am95
1 files changed, 95 insertions, 0 deletions
diff --git a/man-po/Makefile.am b/man-po/Makefile.am
new file mode 100644
index 0000000..87c797f
--- /dev/null
+++ b/man-po/Makefile.am
@@ -0,0 +1,95 @@
+## Process this file with automake to produce Makefile.in
+
+src_MANS = $(wildcard $(top_srcdir)/doc/*.[1-9])
+
+translated_MANS = $(wildcard translated/*/*.[1-9])
+
+EXTRA_DIST = \
+ po4a.cfg \
+ psmisc.pot \
+ $(translated_MANS)
+
+
+# Extract the list of languages from the po4a config file.
+LINGUAS_DIST = $(shell sed -ne 's/^.*\[po4a_langs\] \(.*\)$$/\1/p' $(srcdir)/po4a.cfg)
+
+# If the user has not defined it let's use the default.
+LINGUAS ?= $(LINGUAS_DIST)
+
+
+PO4A_V = $(PO4A_V_@AM_V@)
+PO4A_V_ = $(PO4A_V_@AM_DEFAULT_V@)
+PO4A_V_0 = @echo " PO4A $@";
+
+### PO4A_OPTS = --previous --srcdir $(srcdir) --destdir $(CURDIR) --no-backups \
+### --package-name psmisc --package-version $(PACKAGE_VERSION) \
+### --msgid-bugs-address "Craig Small <csmall@enc.com.au>"
+
+PO4A_OPTS = --previous --srcdir $(srcdir) --destdir $(CURDIR) --no-backups \
+ --package-name $(PACKAGE) --package-version $(VERSION) \
+ --msgid-bugs-address "Craig Small <csmall@dropbear.xyz>"
+
+all-local: all-local-@USE_PO4A@
+
+all-local-no:
+all-local-yes: man.stamp
+
+# FIXME: Use a stamp file until po4a supports them internally.
+man.stamp:
+ $(PO4A_V) $(PO4A) $(PO4A_OPTS) $(srcdir)/po4a.cfg
+ $(AM_V_at) touch $@
+
+clean-local: clean-local-@USE_PO4A@
+
+clean-local-no:
+clean-local-yes:
+ rm -rf $(LINGUAS_DIST)
+ $(AM_V_at) rm -f man.stamp
+
+.PHONY: update-po
+
+psmisc.pot: $(src_MANS)
+ po4a-gettextize -M utf8 --option groff_code=verbatim --option generated --option untranslated="a.RE,\|" --option unknown_macros=untranslated -f man $(patsubst %,-m%,$(subst :, ,$(src_MANS))) -p psmisc.pot
+
+update-po:
+ $(PO4A_V) $(PO4A) $(PO4A_OPTS) --force $(srcdir)/po4a.cfg
+
+
+install-data-local:
+ for lang in $(LINGUAS); do \
+ files=""; \
+ for trans in $(notdir $(src_MANS)); do \
+ if [ -f $(CURDIR)/$$lang/$$trans ]; then \
+ files="$$files $(CURDIR)/$$lang/$$trans"; \
+ elif [ -f $(srcdir)/$$lang/$$trans ]; then \
+ files="$$files $(srcdir)/$$lang/$$trans"; \
+ fi; \
+ done; \
+ $(MAKE) -C .. install-man \
+ mandir="$(mandir)/$$lang" \
+ dist_man_MANS="$$files"; \
+ done
+
+uninstall-local:
+ for lang in $(LINGUAS); do \
+ files=""; \
+ for trans in $(notdir $(src_MANS)); do \
+ if [ -f $(CURDIR)/$$lang/$$trans ]; then \
+ files="$$files $(CURDIR)/$$lang/$$trans"; \
+ elif [ -f $(srcdir)/$$lang/$$trans ]; then \
+ files="$$files $(srcdir)/$$lang/$$trans"; \
+ fi; \
+ done; \
+ $(MAKE) -C .. uninstall-man \
+ mandir="$(mandir)/$$lang" \
+ dist_man_MANS="$$files"; \
+ done
+
+dist-hook: man.stamp
+ cp $(srcdir)/man.stamp $(distdir)/
+ for lang in $(LINGUAS_DIST); do \
+ cp $(srcdir)/$$lang.po $(distdir); \
+ cp $(srcdir)/$$lang.add $(distdir); \
+ $(MKDIR_P) $(distdir)/$$lang; \
+ cp -r $(srcdir)/$$lang $(distdir)/; \
+ done