summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5421c45..ce42037 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.ruff]
target-version = "py37"
-select = [
+lint.select = [
"E", # pycodestyle errors
"W", # pycodestyle warnings
"F", # pyflakes
@@ -12,14 +12,14 @@ select = [
"RUF100", # unused-noqa
"Q", # quotes
]
-ignore = [
+lint.ignore = [
"E501", # Line too long, handled by black
"C901", # Too complex
"E722", # bare except.
]
-[tool.ruff.per-file-ignores]
+[tool.ruff.lint.per-file-ignores]
"examples/*" = ["T201"] # Print allowed in examples.
"examples/ptpython_config/config.py" = ["F401"] # Unused imports in config.
"ptpython/entry_points/run_ptipython.py" = ["T201", "F401"] # Print, import usage.
@@ -30,6 +30,6 @@ ignore = [
"tests/run_tests.py" = ["F401"] # Unused imports.
-[tool.ruff.isort]
+[tool.ruff.lint.isort]
known-first-party = ["ptpython"]
known-third-party = ["prompt_toolkit", "pygments", "asyncssh"]