summaryrefslogtreecommitdiffstats
path: root/.config
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:38:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:38:37 +0000
commit23e67a23a7b57fa5cb6fc92bd0843c3707d56ef9 (patch)
tree88110359f0deb3bb263ade4ed0e888da6b7fdea4 /.config
parentAdding upstream version 24.5.1. (diff)
downloadpython-ansible-compat-upstream.tar.xz
python-ansible-compat-upstream.zip
Adding upstream version 24.6.0.upstream/24.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--.config/python3-ansible-compat.spec66
-rw-r--r--.config/requirements.in2
2 files changed, 67 insertions, 1 deletions
diff --git a/.config/python3-ansible-compat.spec b/.config/python3-ansible-compat.spec
new file mode 100644
index 0000000..362b563
--- /dev/null
+++ b/.config/python3-ansible-compat.spec
@@ -0,0 +1,66 @@
+# spell-checker:ignore bcond pkgversion buildrequires autosetup PYTHONPATH noarch buildroot bindir sitelib numprocesses clib
+# All tests require Internet access
+# to test in mock use: --enable-network --with check
+# to test in a privileged environment use:
+# --with check --with privileged_tests
+%bcond_with check
+%bcond_with privileged_tests
+
+Name: ansible-compat
+Version: VERSION_PLACEHOLDER
+Release: 1%{?dist}
+Summary: Ansible-compat library
+
+License: GPL-3.0-or-later
+URL: https://github.com/ansible/ansible-compat
+Source0: %{pypi_source}
+
+BuildArch: noarch
+
+BuildRequires: python%{python3_pkgversion}-devel
+%if %{with check}
+# These are required for tests:
+BuildRequires: python%{python3_pkgversion}-pytest
+BuildRequires: python%{python3_pkgversion}-pytest-xdist
+BuildRequires: python%{python3_pkgversion}-libselinux
+BuildRequires: git-core
+%endif
+Requires: git-core
+
+
+%description
+Ansible-compat.
+
+%prep
+%autosetup
+
+
+%generate_buildrequires
+%pyproject_buildrequires
+
+
+%build
+%pyproject_wheel
+
+
+%install
+%pyproject_install
+%pyproject_save_files ansible_compat
+
+
+%check
+%pyproject_check_import
+%if %{with check}
+%pytest \
+ -v \
+ --disable-pytest-warnings \
+ --numprocesses=auto \
+ test
+%endif
+
+
+%files -f %{pyproject_files}
+%license LICENSE
+%doc docs/ README.md
+
+%changelog
diff --git a/.config/requirements.in b/.config/requirements.in
index 29c2662..6a9241c 100644
--- a/.config/requirements.in
+++ b/.config/requirements.in
@@ -1,5 +1,5 @@
# https://docs.ansible.com/ansible/latest/reference_appendices/release_and_maintenance.html
-ansible-core>=2.12
+ansible-core>=2.14
packaging
PyYAML
subprocess-tee>=0.4.1