summaryrefslogtreecommitdiffstats
path: root/.packit.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:24:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 00:24:37 +0000
commit1022b2cebe73db426241c2f420d4ee9f6f3c1bed (patch)
treea5c38ccfaa66e8a52767dec01d3598b67a7422a8 /.packit.yaml
parentInitial commit. (diff)
downloadpython-ansible-compat-1022b2cebe73db426241c2f420d4ee9f6f3c1bed.tar.xz
python-ansible-compat-1022b2cebe73db426241c2f420d4ee9f6f3c1bed.zip
Adding upstream version 4.1.11.upstream/4.1.11
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.packit.yaml')
-rw-r--r--.packit.yaml42
1 files changed, 42 insertions, 0 deletions
diff --git a/.packit.yaml b/.packit.yaml
new file mode 100644
index 0000000..575e351
--- /dev/null
+++ b/.packit.yaml
@@ -0,0 +1,42 @@
+---
+# https://packit.dev/docs/configuration/
+# Test locally running: packit build locally
+# spell-checker:ignore packit specfile copr epel
+specfile_path: dist/python-ansible-compat.spec
+actions:
+ create-archive:
+ # packit.dev service does have these module pre-installed:
+ - python3 -m build --sdist --outdir dist
+ - sh -c "ls dist/ansible-compat-*.tar.gz"
+ get-current-version:
+ - ./tools/get-version.sh
+ post-upstream-clone:
+ - rm -f dist/*.tar.gz || true
+ - ./tools/update-version.sh
+srpm_build_deps:
+ - python3-build
+ - python3-setuptools_scm
+ - python3-pytest
+ - python3-pytest-mock
+jobs:
+ - job: copr_build
+ trigger: commit
+ branch: main
+ targets:
+ - fedora-rawhide-x86_64
+ - fedora-rawhide-aarch64
+ - fedora-latest-x86_64
+ - fedora-latest-aarch64
+ # Missing python3-build see https://bugzilla.redhat.com/show_bug.cgi?id=2129071
+ # - centos-stream-9-aarch64
+ # - centos-stream-9-x86_64
+ - job: tests
+ trigger: pull_request
+ branch: main
+ targets:
+ - fedora-latest
+ - fedora-rawhide
+ # - job: propose_downstream
+ # trigger: release
+ # metadata:
+ # dist-git-branch: master