summaryrefslogtreecommitdiffstats
path: root/.packit.yaml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--.packit.yaml14
1 files changed, 8 insertions, 6 deletions
diff --git a/.packit.yaml b/.packit.yaml
index 575e351..cc5d215 100644
--- a/.packit.yaml
+++ b/.packit.yaml
@@ -2,17 +2,16 @@
# https://packit.dev/docs/configuration/
# Test locally running: packit build locally
# spell-checker:ignore packit specfile copr epel
-specfile_path: dist/python-ansible-compat.spec
+specfile_path: dist/python3-ansible-compat.spec
actions:
create-archive:
- # packit.dev service does have these module pre-installed:
+ - sh -c "rm dist/*.tar.gz || true"
- python3 -m build --sdist --outdir dist
- - sh -c "ls dist/ansible-compat-*.tar.gz"
+ - sh -c "ls dist/ansible_compat-*.tar.gz"
get-current-version:
- ./tools/get-version.sh
post-upstream-clone:
- - rm -f dist/*.tar.gz || true
- - ./tools/update-version.sh
+ - ./tools/update-spec.sh
srpm_build_deps:
- python3-build
- python3-setuptools_scm
@@ -20,7 +19,7 @@ srpm_build_deps:
- python3-pytest-mock
jobs:
- job: copr_build
- trigger: commit
+ trigger: pull_request
branch: main
targets:
- fedora-rawhide-x86_64
@@ -40,3 +39,6 @@ jobs:
# trigger: release
# metadata:
# dist-git-branch: master
+notifications:
+ pull_request:
+ successful_build: false