summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:08:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:08:34 +0000
commit24282b3793f0e5adf4741db7a98c03a5d251a943 (patch)
tree70cd9c8c81e6d63202a5798e8c819bb66cfcf405 /debian
parentUpdating source format. (diff)
downloadpython-apt-24282b3793f0e5adf4741db7a98c03a5d251a943.tar.xz
python-apt-24282b3793f0e5adf4741db7a98c03a5d251a943.zip
Updating PEP440 version handling to fix FTBFS with Progress Linux versions.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 10ce354..a3b8c64 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,6 @@
#!/usr/bin/make -f
# Should be include-links, but that somehow fails.
-export DEBVER=$(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
+export DEBVER=$(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p' | sed -e 's|-.*||')
export DATETIME:=$(shell dpkg-parsechangelog | sed -n -e 's/^Date: //p')
export DATE_CMD:=env TZ=UTC LC_ALL=C.UTF-8 date
export DATE:=$(shell $(DATE_CMD) --date="$(DATETIME)" "+%b %_d %Y")