summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:40:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:40:06 +0000
commit571f395a5a6f29a0a62d4274199ddd930de5fef9 (patch)
treeb0bc3d72bf13424b383a75af57c68b721a96b9fe /debian/rules
parentAdding upstream version 2.0.16. (diff)
downloadraptor2-571f395a5a6f29a0a62d4274199ddd930de5fef9.tar.xz
raptor2-571f395a5a6f29a0a62d4274199ddd930de5fef9.zip
Adding debian version 2.0.16-3.debian/2.0.16-3debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b6ba7a7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--default-symver
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-gtk-doc
+
+override_dh_auto_test:
+ dh_auto_test --no-parallel