summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:40:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:40:05 +0000
commit4038ab95a094b363f1748f3dcb51511a1217475d (patch)
tree7f393d66a783f91ddd263c78d681e485cf4f45ca /scripts/Makefile.am
parentInitial commit. (diff)
downloadraptor2-4038ab95a094b363f1748f3dcb51511a1217475d.tar.xz
raptor2-4038ab95a094b363f1748f3dcb51511a1217475d.zip
Adding upstream version 2.0.16.upstream/2.0.16upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--scripts/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
new file mode 100644
index 0000000..5591adb
--- /dev/null
+++ b/scripts/Makefile.am
@@ -0,0 +1,45 @@
+# -*- Mode: Makefile -*-
+#
+# Makefile.am - automake file for Raptor libraptor
+#
+# Copyright (C) 2010, David Beckett http://www.dajobe.org/
+#
+# This package is Free Software and part of Redland http://librdf.org/
+#
+# It is licensed under the following three licenses as alternatives:
+# 1. GNU Lesser General Public License (LGPL) V2.1 or any newer version
+# 2. GNU General Public License (GPL) V2 or any newer version
+# 3. Apache License, V2.0 or any newer version
+#
+# You may not use this file except in compliance with at least one of
+# the above three licenses.
+#
+# See LICENSE.html or LICENSE.txt at the top of this package for the
+# complete terms and further detail along with the license texts for
+# the licenses in COPYING.LIB, COPYING and LICENSE-2.0.txt respectively.
+#
+
+EXTRA_DIST= \
+fix-bison.pl \
+fix-flex.pl \
+fix-groff-xhtml.pl \
+fix-gtkdoc-header.pl \
+process-changes.pl \
+rdfcompare
+
+CLEANFILES =
+
+AM_CPPFLAGS= -I$(top_srcdir)/src
+
+if MAINTAINER_MODE
+EXTRA_PROGRAMS = build-formats
+
+CLEANFILES += build-formats
+
+build_formats_SOURCES = build-formats.c
+build_formats_LDADD= $(top_builddir)/src/libraptor2.la
+
+endif
+
+$(top_builddir)/src/libraptor2.la:
+ cd $(top_builddir)/src && $(MAKE) libraptor2.la