summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:40:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:40:05 +0000
commit4038ab95a094b363f1748f3dcb51511a1217475d (patch)
tree7f393d66a783f91ddd263c78d681e485cf4f45ca /utils/CMakeLists.txt
parentInitial commit. (diff)
downloadraptor2-4038ab95a094b363f1748f3dcb51511a1217475d.tar.xz
raptor2-4038ab95a094b363f1748f3dcb51511a1217475d.zip
Adding upstream version 2.0.16.upstream/2.0.16upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
new file mode 100644
index 0000000..0067e4c
--- /dev/null
+++ b/utils/CMakeLists.txt
@@ -0,0 +1,26 @@
+# raptor/utils/CMakeLists.txt
+#
+# Original listfile by Daniel Richard G. <skunk@iSKUNK.ORG>
+# This file is in the public domain.
+#
+
+INCLUDE_DIRECTORIES(BEFORE
+ ${CMAKE_CURRENT_SOURCE_DIR}/../src
+ ${CMAKE_BINARY_DIR}/src
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+IF(NOT HAVE_GETOPT AND NOT HAVE_GETOPT_LONG)
+ SET(getopt_sources getopt.c raptor_getopt.h)
+ENDIF(NOT HAVE_GETOPT AND NOT HAVE_GETOPT_LONG)
+
+ADD_EXECUTABLE(rapper rapper.c ${getopt_sources})
+TARGET_LINK_LIBRARIES(rapper raptor2)
+
+ADD_EXECUTABLE(rdfdiff rdfdiff.c ${getopt_sources})
+TARGET_LINK_LIBRARIES(rdfdiff raptor2)
+
+INSTALL(FILES rapper.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+INSTALL(TARGETS rapper DESTINATION ${CMAKE_INSTALL_BINDIR})
+
+# end raptor/utils/CMakeLists.txt