summaryrefslogtreecommitdiffstats
path: root/plugins/kwallet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/kwallet/CMakeLists.txt')
-rw-r--r--plugins/kwallet/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/plugins/kwallet/CMakeLists.txt b/plugins/kwallet/CMakeLists.txt
new file mode 100644
index 0000000..a448e31
--- /dev/null
+++ b/plugins/kwallet/CMakeLists.txt
@@ -0,0 +1,54 @@
+# remmina-plugin-www - The GTK+ Remote Desktop Client
+#
+# Copyright (C) 2016-2023 Antenore Gatta, Giovanni Panozzo
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+#
+# In addition, as a special exception, the copyright holders give
+# permission to link the code of portions of this program with the
+# OpenSSL library under certain conditions as described in each
+# individual source file, and distribute linked combinations
+# including the two.
+# You must obey the GNU General Public License in all respects
+# for all of the code used other than OpenSSL. If you modify
+# file(s) with this exception, you may extend this exception to your
+# version of the file(s), but you are not obligated to do so. If you
+# do not wish to do so, delete this exception statement from your
+# version. If you delete this exception statement from all source
+# files in the program, then also delete it here.
+
+
+
+# find_suggested_package(KF5Wallet) has already been run on main CMakeLists.txt
+
+find_suggested_package(KF5Wallet)
+if(KF5Wallet_FOUND)
+ message(STATUS "KF5Wallet library found.")
+ set(REMMINA_PLUGIN_KF5WALLET_SRCS
+ src/kwallet_plugin_main.c
+ src/kwallet_plugin.cpp
+ src/kwallet_plugin.h
+ )
+
+ add_library(remmina-plugin-kwallet MODULE ${REMMINA_PLUGIN_KF5WALLET_SRCS})
+ set_target_properties(remmina-plugin-kwallet PROPERTIES PREFIX "")
+ set_target_properties(remmina-plugin-kwallet PROPERTIES NO_SONAME 1)
+
+ include_directories(${GTK_INCLUDE_DIRS})
+ target_link_libraries(remmina-plugin-kwallet KF5::Wallet ${GLib_LIBRARY})
+
+ install(TARGETS remmina-plugin-kwallet DESTINATION ${REMMINA_PLUGINDIR})
+endif()