summaryrefslogtreecommitdiffstats
path: root/plugins/x2go/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/x2go/CMakeLists.txt')
-rw-r--r--plugins/x2go/CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/plugins/x2go/CMakeLists.txt b/plugins/x2go/CMakeLists.txt
new file mode 100644
index 0000000..97df070
--- /dev/null
+++ b/plugins/x2go/CMakeLists.txt
@@ -0,0 +1,66 @@
+#
+# Project: Remmina Plugin X2Go
+# Description: Remmina protocol plugin to connect via X2Go using PyHoca
+# Based on Fabio Castelli Team Viewer Plugin
+# Copyright: 2013-2014 Fabio Castelli (Muflone)
+# Author: Antenore Gatta <antenore@simbiosi.org>
+# Copyright: 2015 Antenore Gatta
+# License: GPL-2+
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+#
+# In addition, as a special exception, the copyright holders give
+# permission to link the code of portions of this program with the
+# OpenSSL library under certain conditions as described in each
+# individual source file, and distribute linked combinations
+# including the two.
+# You must obey the GNU General Public License in all respects
+# for all of the code used other than OpenSSL. * If you modify
+# file(s) with this exception, you may extend this exception to your
+# version of the file(s), but you are not obligated to do so. * If you
+# do not wish to do so, delete this exception statement from your
+# version. * If you delete this exception statement from all source
+# files in the program, then also delete it here.
+
+set(REMMINA_PLUGIN_X2GO_SRCS
+ x2go_plugin.c
+ x2go_plugin.h
+ )
+
+add_library(remmina-plugin-x2go MODULE ${REMMINA_PLUGIN_X2GO_SRCS})
+set_target_properties(remmina-plugin-x2go PROPERTIES PREFIX "")
+set_target_properties(remmina-plugin-x2go PROPERTIES NO_SONAME 1)
+
+find_package(X11)
+
+include_directories(${REMMINA_COMMON_INCLUDE_DIRS}
+ ${XKBFILE_INCLUDE_DIRS} ${LIBSSH_INCLUDE_DIRS})
+target_link_libraries(remmina-plugin-x2go
+ ${REMMINA_COMMON_LIBRARIES}
+ ${XKBFILE_LIBRARIES}
+ ${LIBSSH_LIBRARIES}
+ ${X11_X11_LIB})
+
+install(TARGETS remmina-plugin-x2go DESTINATION ${REMMINA_PLUGINDIR})
+
+install(FILES
+ scalable/emblems/org.remmina.Remmina-x2go-ssh-symbolic.svg
+ scalable/emblems/org.remmina.Remmina-x2go-symbolic.svg
+ DESTINATION ${APPICONSCALE_EMBLEMS_DIR})
+
+if(WITH_ICON_CACHE)
+ gtk_update_icon_cache("${REMMINA_DATADIR}/icons/hicolor")
+endif()