summaryrefslogtreecommitdiffstats
path: root/src/external_tools
diff options
context:
space:
mode:
Diffstat (limited to 'src/external_tools')
-rw-r--r--src/external_tools/CMakeLists.txt44
-rwxr-xr-xsrc/external_tools/functions.sh16
-rwxr-xr-xsrc/external_tools/launcher.sh28
-rwxr-xr-xsrc/external_tools/remmina_filezilla_sftp.sh7
-rwxr-xr-xsrc/external_tools/remmina_filezilla_sftp_pki.sh7
-rwxr-xr-xsrc/external_tools/remmina_nslookup.sh8
-rwxr-xr-xsrc/external_tools/remmina_ping.sh8
-rwxr-xr-xsrc/external_tools/remmina_traceroute.sh8
8 files changed, 126 insertions, 0 deletions
diff --git a/src/external_tools/CMakeLists.txt b/src/external_tools/CMakeLists.txt
new file mode 100644
index 0000000..f7b17cf
--- /dev/null
+++ b/src/external_tools/CMakeLists.txt
@@ -0,0 +1,44 @@
+# desktop/remmina - The GTK+ Remote Desktop Client
+#
+# Copyright (C) 2011 Marc-Andre Moreau
+# Copyright (C) 2014-2023 Antenore Gatta, Giovanni Panozzo
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+#
+# In addition, as a special exception, the copyright holders give
+# permission to link the code of portions of this program with the
+# OpenSSL library under certain conditions as described in each
+# individual source file, and distribute linked combinations
+# including the two.
+# You must obey the GNU General Public License in all respects
+# for all of the code used other than OpenSSL. If you modify
+# file(s) with this exception, you may extend this exception to your
+# version of the file(s), but you are not obligated to do so. If you
+# do not wish to do so, delete this exception statement from your
+# version. If you delete this exception statement from all source
+# files in the program, then also delete it here.
+
+INSTALL(PROGRAMS
+ launcher.sh
+ functions.sh
+ remmina_filezilla_sftp.sh
+ remmina_filezilla_sftp_pki.sh
+ remmina_nslookup.sh
+ remmina_ping.sh
+ remmina_traceroute.sh
+ DESTINATION ${REMMINA_EXTERNAL_TOOLS_DIR})
+
+
diff --git a/src/external_tools/functions.sh b/src/external_tools/functions.sh
new file mode 100755
index 0000000..2f70eaf
--- /dev/null
+++ b/src/external_tools/functions.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# Awaits user key press.
+pause ()
+{
+ echo "Press any key to continue…"
+ OLDCONFIG=$(stty -g)
+ stty -icanon -echo min 1 time 0
+ dd count=1 2>/dev/null
+ stty $OLDCONFIG
+}
+
+# Set terminal title for gnome-terminal and many others
+settitle() {
+ echo -n -e "\033]0;${remmina_term_title}\007"
+}
diff --git a/src/external_tools/launcher.sh b/src/external_tools/launcher.sh
new file mode 100755
index 0000000..ff056cc
--- /dev/null
+++ b/src/external_tools/launcher.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+####################
+# Main Script
+####################
+
+TERMINALS="xfce4-terminal gnome-terminal x-terminal-emulator"
+
+for t in $TERMINALS; do
+ TERMBIN="$(command -v "$t")"
+ if [ "$?" -eq 0 ]; then
+ case "$t" in
+ xfce4-terminal)
+ TERMBIN="$TERMBIN --disable-server"
+ break
+ ;;
+ gnome-terminal)
+ break
+ ;;
+ x-terminal-emulator)
+ break
+ ;;
+ esac
+ fi
+done
+
+$TERMBIN -e "$1" &
+
diff --git a/src/external_tools/remmina_filezilla_sftp.sh b/src/external_tools/remmina_filezilla_sftp.sh
new file mode 100755
index 0000000..63c1b11
--- /dev/null
+++ b/src/external_tools/remmina_filezilla_sftp.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+. $(dirname $0)/functions.sh
+settitle
+
+filezilla sftp://$username:"$password"@$server
+
diff --git a/src/external_tools/remmina_filezilla_sftp_pki.sh b/src/external_tools/remmina_filezilla_sftp_pki.sh
new file mode 100755
index 0000000..5b1ac50
--- /dev/null
+++ b/src/external_tools/remmina_filezilla_sftp_pki.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+. $(dirname $0)/functions.sh
+settitle
+
+filezilla sftp://$ssh_username@$server
+
diff --git a/src/external_tools/remmina_nslookup.sh b/src/external_tools/remmina_nslookup.sh
new file mode 100755
index 0000000..9f48953
--- /dev/null
+++ b/src/external_tools/remmina_nslookup.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+. $(dirname $0)/functions.sh
+settitle
+
+nslookup $server
+
+pause
diff --git a/src/external_tools/remmina_ping.sh b/src/external_tools/remmina_ping.sh
new file mode 100755
index 0000000..f69fe5e
--- /dev/null
+++ b/src/external_tools/remmina_ping.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+. $(dirname $0)/functions.sh
+settitle
+
+ping -c3 $server
+
+pause
diff --git a/src/external_tools/remmina_traceroute.sh b/src/external_tools/remmina_traceroute.sh
new file mode 100755
index 0000000..3b5d8cc
--- /dev/null
+++ b/src/external_tools/remmina_traceroute.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+. $(dirname $0)/functions.sh
+settitle
+
+traceroute $server
+
+pause