summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:52:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:52:36 +0000
commit7de03e4e519705301265c0415b3c0af85263a7ac (patch)
tree29d819c5227e3619d18a67d2a5dde963b3229dbe /tools/Makefile.am
parentInitial commit. (diff)
downloadresource-agents-7de03e4e519705301265c0415b3c0af85263a7ac.tar.xz
resource-agents-7de03e4e519705301265c0415b3c0af85263a7ac.zip
Adding upstream version 1:4.13.0.upstream/1%4.13.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am85
1 files changed, 85 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..55e292c
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,85 @@
+#
+# heartbeat: Linux-HA heartbeat code
+#
+# Copyright (C) 2001 Michael Moerz
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+MAINTAINERCLEANFILES = Makefile.in
+
+SUBDIRS = ocft
+
+AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include
+
+halibdir = $(libexecdir)/heartbeat
+
+EXTRA_DIST = ocf-tester.8 sfex_init.8
+
+sbin_PROGRAMS =
+sbin_SCRIPTS = ocf-tester
+halib_PROGRAMS = findif \
+ storage_mon
+halib_SCRIPTS =
+
+man8_MANS = ocf-tester.8
+
+if BUILD_SFEX
+halib_PROGRAMS += sfex_daemon
+sbin_PROGRAMS += sfex_init sfex_stat
+man8_MANS += sfex_init.8
+endif
+
+if USE_LIBNET
+halib_PROGRAMS += send_arp
+send_arp_SOURCES = send_arp.libnet.c
+send_arp_CFLAGS = @LIBNETDEFINES@
+send_arp_LDADD = $(GLIBLIB) -lplumb @LIBNETLIBS@
+else
+
+if SENDARP_LINUX
+halib_PROGRAMS += send_arp
+send_arp_SOURCES = send_arp.linux.c
+endif
+
+if NFSCONVERT
+halib_SCRIPTS += nfsconvert
+endif
+
+endif
+
+sfex_daemon_SOURCES = sfex_daemon.c sfex.h sfex_lib.c sfex_lib.h
+sfex_daemon_CFLAGS = -D_GNU_SOURCE
+sfex_daemon_LDADD = $(GLIBLIB) -lplumb -lplumbgpl
+
+sfex_init_SOURCES = sfex_init.c sfex.h sfex_lib.c sfex_lib.h
+sfex_init_CFLAGS = -D_GNU_SOURCE
+sfex_init_LDADD = $(GLIBLIB) -lplumb -lplumbgpl
+
+sfex_stat_SOURCES = sfex_stat.c sfex.h sfex_lib.c sfex_lib.h
+sfex_stat_CFLAGS = -D_GNU_SOURCE
+sfex_stat_LDADD = $(GLIBLIB) -lplumb -lplumbgpl
+
+findif_SOURCES = findif.c
+
+storage_mon_SOURCES = storage_mon.c
+storage_mon_CFLAGS = -D_GNU_SOURCE ${LIBQB_CFLAGS}
+storage_mon_LDADD = ${LIBQB_LIBS}
+
+if BUILD_TICKLE
+halib_PROGRAMS += tickle_tcp
+tickle_tcp_SOURCES = tickle_tcp.c
+endif
+
+.PHONY: install-exec-hook