summaryrefslogtreecommitdiffstats
path: root/tools/ocft/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:52:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:52:36 +0000
commit7de03e4e519705301265c0415b3c0af85263a7ac (patch)
tree29d819c5227e3619d18a67d2a5dde963b3229dbe /tools/ocft/Makefile.am
parentInitial commit. (diff)
downloadresource-agents-7de03e4e519705301265c0415b3c0af85263a7ac.tar.xz
resource-agents-7de03e4e519705301265c0415b3c0af85263a7ac.zip
Adding upstream version 1:4.13.0.upstream/1%4.13.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/ocft/Makefile.am')
-rw-r--r--tools/ocft/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/tools/ocft/Makefile.am b/tools/ocft/Makefile.am
new file mode 100644
index 0000000..69c59ee
--- /dev/null
+++ b/tools/ocft/Makefile.am
@@ -0,0 +1,63 @@
+# Author: John Shi
+# jshi@suse.de
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+MAINTAINERCLEANFILES = Makefile.in
+
+EXTRA_DIST = $(ocftcfgs_DATA) $(ocft_DATA) $(ocft_SCRIPTS)
+
+sbin_SCRIPTS = ocft
+
+ocftcfgsdir = $(datadir)/$(PACKAGE_NAME)/ocft/configs
+ocftcfgs_DATA = apache \
+ IPaddr2 \
+ IPaddr2v4 \
+ IPaddr2v6 \
+ IPv6addr \
+ Filesystem \
+ LVM \
+ Raid1 \
+ IPsrcaddr \
+ MailTo \
+ jboss \
+ mysql \
+ mysql-proxy \
+ pgsql \
+ db2 \
+ oracle \
+ drbd.linbit \
+ exportfs \
+ exportfs-multidir \
+ nfsserver \
+ portblock \
+ iscsi \
+ named \
+ postfix \
+ sg_persist \
+ tomcat \
+ Xinetd \
+ Xen \
+ VirtualDomain \
+ SendArp
+
+ocftdir = $(datadir)/$(PACKAGE_NAME)/ocft
+ocft_DATA = README \
+ README.zh_CN \
+ caselib \
+ helpers.sh \
+ runocft.prereq
+ocft_SCRIPTS = runocft
+