summaryrefslogtreecommitdiffstats
path: root/ldirectord/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ldirectord/Makefile.am')
-rw-r--r--ldirectord/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/ldirectord/Makefile.am b/ldirectord/Makefile.am
new file mode 100644
index 0000000..5641e07
--- /dev/null
+++ b/ldirectord/Makefile.am
@@ -0,0 +1,45 @@
+#
+# ldirectord: Linux-HA heartbeat code
+#
+# Copyright (C) 2001 Michael Moerz
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+MAINTAINERCLEANFILES = Makefile.in
+CLEANFILES = ldirectord.8
+
+EXTRA_DIST = ldirectord ldirectord.cf
+
+SUBDIRS = logrotate.d init.d OCF systemd
+
+ldirectord.8: ldirectord
+ $(POD2MAN) --section=8 $< > $@
+
+sbin_SCRIPTS = ldirectord
+
+if BUILD_POD_DOC
+man_MANS = ldirectord.8
+endif
+
+harddir = $(sysconfdir)/ha.d/resource.d
+
+.PHONY: install-exec-hook
+install-exec-hook:
+ $(INSTALL) -d $(DESTDIR)$(harddir)
+ cd $(DESTDIR)$(harddir) && ln -s -f $(sbindir)/ldirectord .
+
+.PHONY: uninstall-hook
+uninstall-hook:
+ rm -f $(DESTDIR)$(harddir)/ldirectord