summaryrefslogtreecommitdiffstats
path: root/ci
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 19:22:08 +0000
commit55fffa809312f6c0ae40528fd1ee66b7559c4650 (patch)
treebb6b3e63b35220d36bdc654f784a985e88ba1cd2 /ci
parentReleasing progress-linux version 0.17.0-3~progress7.99u1. (diff)
downloadrnp-55fffa809312f6c0ae40528fd1ee66b7559c4650.tar.xz
rnp-55fffa809312f6c0ae40528fd1ee66b7559c4650.zip
Merging upstream version 0.17.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xci-legacy/build_package_rpm.sh (renamed from ci/build_package_rpm.sh)0
-rw-r--r--ci-legacy/env-common.inc.sh (renamed from ci/env-common.inc.sh)4
-rw-r--r--ci-legacy/env-freebsd.inc.sh (renamed from ci/env-freebsd.inc.sh)0
-rw-r--r--ci-legacy/env-linux.inc.sh (renamed from ci/env-linux.inc.sh)0
-rw-r--r--ci-legacy/env.inc.sh (renamed from ci/env.inc.sh)0
-rw-r--r--ci-legacy/gha/setup-env.inc.sh (renamed from ci/gha/setup-env.inc.sh)0
-rwxr-xr-xci-legacy/install.sh (renamed from ci/install.sh)0
-rwxr-xr-xci-legacy/install_cacheable_dependencies.sh (renamed from ci/install_cacheable_dependencies.sh)0
-rwxr-xr-xci-legacy/install_noncacheable_dependencies.sh (renamed from ci/install_noncacheable_dependencies.sh)0
-rw-r--r--ci-legacy/lib/cacheable_install_functions.inc.sh (renamed from ci/lib/cacheable_install_functions.inc.sh)24
-rw-r--r--ci-legacy/lib/install_functions.inc.sh (renamed from ci/lib/install_functions.inc.sh)0
-rwxr-xr-xci-legacy/local.sh (renamed from ci/local.sh)0
-rwxr-xr-xci-legacy/main.sh (renamed from ci/main.sh)0
-rwxr-xr-xci-legacy/run.sh (renamed from ci/run.sh)0
-rwxr-xr-xci-legacy/style-check.sh (renamed from ci/style-check.sh)0
-rwxr-xr-xci-legacy/success.sh (renamed from ci/success.sh)0
-rw-r--r--ci-legacy/utils.inc.sh (renamed from ci/utils.inc.sh)0
-rw-r--r--ci/botan3-modules46
-rw-r--r--ci/docker/Makefile11
-rw-r--r--ci/docker/fedora35.Dockerfile52
-rwxr-xr-xci/docker/fedora35.test-locally22
-rwxr-xr-xci/tests/ci-tests.sh6
-rwxr-xr-xci/tests/deb-tests.sh2
-rwxr-xr-xci/tests/pk-tests.sh31
-rwxr-xr-xci/tests/pkg-tests.sh2
-rwxr-xr-xci/tests/rpm-tests.sh2
26 files changed, 66 insertions, 136 deletions
diff --git a/ci/build_package_rpm.sh b/ci-legacy/build_package_rpm.sh
index 645bf5d..645bf5d 100755
--- a/ci/build_package_rpm.sh
+++ b/ci-legacy/build_package_rpm.sh
diff --git a/ci/env-common.inc.sh b/ci-legacy/env-common.inc.sh
index 11712f0..1e2f9ed 100644
--- a/ci/env-common.inc.sh
+++ b/ci-legacy/env-common.inc.sh
@@ -21,9 +21,5 @@ if [ "$BUILD_MODE" = "sanitize" ]; then
export CC=clang
fi
-BOTAN_MODULES=$(<ci/botan-modules tr '\n' ',')
-
-export BOTAN_MODULES
-
# Don't clean up tempdirs when in CI runners to save time. Unset to disable.
export RNP_KEEP_TEMP=1
diff --git a/ci/env-freebsd.inc.sh b/ci-legacy/env-freebsd.inc.sh
index 3509111..3509111 100644
--- a/ci/env-freebsd.inc.sh
+++ b/ci-legacy/env-freebsd.inc.sh
diff --git a/ci/env-linux.inc.sh b/ci-legacy/env-linux.inc.sh
index 9267972..9267972 100644
--- a/ci/env-linux.inc.sh
+++ b/ci-legacy/env-linux.inc.sh
diff --git a/ci/env.inc.sh b/ci-legacy/env.inc.sh
index ab2271f..ab2271f 100644
--- a/ci/env.inc.sh
+++ b/ci-legacy/env.inc.sh
diff --git a/ci/gha/setup-env.inc.sh b/ci-legacy/gha/setup-env.inc.sh
index c0aca85..c0aca85 100644
--- a/ci/gha/setup-env.inc.sh
+++ b/ci-legacy/gha/setup-env.inc.sh
diff --git a/ci/install.sh b/ci-legacy/install.sh
index 9d90265..9d90265 100755
--- a/ci/install.sh
+++ b/ci-legacy/install.sh
diff --git a/ci/install_cacheable_dependencies.sh b/ci-legacy/install_cacheable_dependencies.sh
index ea23ad6..ea23ad6 100755
--- a/ci/install_cacheable_dependencies.sh
+++ b/ci-legacy/install_cacheable_dependencies.sh
diff --git a/ci/install_noncacheable_dependencies.sh b/ci-legacy/install_noncacheable_dependencies.sh
index bfb93da..bfb93da 100755
--- a/ci/install_noncacheable_dependencies.sh
+++ b/ci-legacy/install_noncacheable_dependencies.sh
diff --git a/ci/lib/cacheable_install_functions.inc.sh b/ci-legacy/lib/cacheable_install_functions.inc.sh
index 6ef35bb..b58d8d9 100644
--- a/ci/lib/cacheable_install_functions.inc.sh
+++ b/ci-legacy/lib/cacheable_install_functions.inc.sh
@@ -14,20 +14,26 @@
install_botan() {
# botan
local botan_build=${LOCAL_BUILDS}/botan
- if [[ ! -e "${BOTAN_INSTALL}/lib/libbotan-2.so" ]] && \
- [[ ! -e "${BOTAN_INSTALL}/lib/libbotan-2.dylib" ]] && \
- [[ ! -e "${BOTAN_INSTALL}/lib/libbotan-2.a" ]]; then
+ local botan_v=${BOTAN_VERSION::1}
+ if [[ ! -e "${BOTAN_INSTALL}/lib/libbotan-${botan_v}.so" ]] && \
+ [[ ! -e "${BOTAN_INSTALL}/lib/libbotan-${botan_v}.dylib" ]] && \
+ [[ ! -e "${BOTAN_INSTALL}/lib/libbotan-${botan_v}.a" ]]; then
if [[ -d "${botan_build}" ]]; then
rm -rf "${botan_build}"
fi
git clone --depth 1 --branch "${BOTAN_VERSION}" https://github.com/randombit/botan "${botan_build}"
- pushd "${botan_build}"
local osparam=()
local cpuparam=()
local run=run
+ local osslparam=()
+ local modules=""
+ [[ "${botan_v}" == "2" ]] && osslparam+=("--without-openssl") && modules=$(<ci/botan-modules tr '\n' ',')
+ [[ "${botan_v}" == "3" ]] && modules=$(<ci/botan3-modules tr '\n' ',')
+
+ pushd "${botan_build}"
# Position independent code is a default for shared libraries at any xNIX platform
# but it makes no sense and is not supported for Windows
local extra_cflags="-fPIC"
@@ -47,8 +53,8 @@ install_botan() {
is_use_static_dependencies && build_target="static,cli"
"${run}" ./configure.py --prefix="${BOTAN_INSTALL}" --with-debug-info --extra-cxxflags="-fno-omit-frame-pointer ${extra_cflags}" \
- ${osparam+"${osparam[@]}"} ${cpuparam+"${cpuparam[@]}"} --without-documentation --without-openssl --build-targets="${build_target}" \
- --minimized-build --enable-modules="$BOTAN_MODULES"
+ ${osparam+"${osparam[@]}"} ${cpuparam+"${cpuparam[@]}"} --without-documentation ${osslparam+"${osslparam[@]}"} --build-targets="${build_target}" \
+ --minimized-build --enable-modules="$modules"
${MAKE} -j"${MAKE_PARALLEL}" install
popd
fi
@@ -224,11 +230,11 @@ install_gpg() {
# npth libgpg-error libgcrypt libassuan libksba pinentry gnupg
_install_gpg component-version 1.6 1.46 1.8.10 2.5.5 1.6.3 1.2.1 2.2.41
;;
- beta)
+ # beta)
# npth libgpg-error libgcrypt libassuan libksba pinentry gnupg
- _install_gpg component-git-ref 2501a48 f73605e d9c4183 909133b 3df0cd3 0e2e53c c6702d7
+ # _install_gpg component-git-ref 2501a48 f73605e d9c4183 909133b 3df0cd3 0e2e53c c6702d7
# _install_gpg component-git-ref 7e45b50 c66594d cf88dca 57cf9d6 4243085 6e8ad31 d4e5979
- ;;
+ # ;;
"2.3.1")
# npth libgpg-error libgcrypt libassuan libksba pinentry gnupg
_install_gpg component-version 1.6 1.42 1.9.3 2.5.5 1.6.0 1.1.1 2.3.1
diff --git a/ci/lib/install_functions.inc.sh b/ci-legacy/lib/install_functions.inc.sh
index 98acc82..98acc82 100644
--- a/ci/lib/install_functions.inc.sh
+++ b/ci-legacy/lib/install_functions.inc.sh
diff --git a/ci/local.sh b/ci-legacy/local.sh
index db687ff..db687ff 100755
--- a/ci/local.sh
+++ b/ci-legacy/local.sh
diff --git a/ci/main.sh b/ci-legacy/main.sh
index c8d80c9..c8d80c9 100755
--- a/ci/main.sh
+++ b/ci-legacy/main.sh
diff --git a/ci/run.sh b/ci-legacy/run.sh
index b9e366c..b9e366c 100755
--- a/ci/run.sh
+++ b/ci-legacy/run.sh
diff --git a/ci/style-check.sh b/ci-legacy/style-check.sh
index 683bbcd..683bbcd 100755
--- a/ci/style-check.sh
+++ b/ci-legacy/style-check.sh
diff --git a/ci/success.sh b/ci-legacy/success.sh
index 1a34be7..1a34be7 100755
--- a/ci/success.sh
+++ b/ci-legacy/success.sh
diff --git a/ci/utils.inc.sh b/ci-legacy/utils.inc.sh
index 618df78..618df78 100644
--- a/ci/utils.inc.sh
+++ b/ci-legacy/utils.inc.sh
diff --git a/ci/botan3-modules b/ci/botan3-modules
new file mode 100644
index 0000000..40f5a26
--- /dev/null
+++ b/ci/botan3-modules
@@ -0,0 +1,46 @@
+aead
+aes
+auto_rng
+bigint
+blowfish
+camellia
+cast128
+cbc
+cfb
+crc24
+curve25519
+des
+dl_algo
+dl_group
+dsa
+eax
+ecc_key
+ecdh
+ecdsa
+ed25519
+elgamal
+eme_pkcs1
+emsa_pkcs1
+emsa_raw
+ffi
+hash
+raw_hash
+hmac
+hmac_drbg
+idea
+kdf
+md5
+ocb
+pgp_s2k
+rfc3394
+rmd160
+rsa
+sha1
+sha2_32
+sha2_64
+sha3
+sm2
+sm3
+sm4
+sp800_56a
+twofish
diff --git a/ci/docker/Makefile b/ci/docker/Makefile
deleted file mode 100644
index b5e9877..0000000
--- a/ci/docker/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-all: fedora35.pushed
-clean:
- rm *.built *.pushed
-.PHONY: all clean
-
-fedora35.built:
- cd ../.. && docker build --squash -t andreyutkin/rnp-ci-fedora:35 -f ci/docker/fedora35.Dockerfile .
- touch $@
-fedora35.pushed: fedora35.built
- docker push andreyutkin/rnp-ci-fedora:35
- touch $@
diff --git a/ci/docker/fedora35.Dockerfile b/ci/docker/fedora35.Dockerfile
deleted file mode 100644
index dd71b05..0000000
--- a/ci/docker/fedora35.Dockerfile
+++ /dev/null
@@ -1,52 +0,0 @@
-FROM fedora:35
-RUN dnf makecache
-RUN dnf -y install \
-autoconf \
-automake \
-bison \
-botan2 \
-botan2-devel \
-byacc \
-bzip2 \
-bzip2-devel \
-clang \
-cmake \
-gcc \
-gcc-c++ \
-gettext-devel \
-git \
-gtest \
-gtest-devel \
-gzip \
-json-c \
-json-c-devel \
-libtool \
-make \
-ncurses-devel \
-openssl \
-openssl-devel \
-openssl-libs \
-python3 \
-ruby-devel \
-rubygem-asciidoctor \
-sudo \
-wget \
-zlib-devel \
-;
-RUN dnf clean all
-
-RUN useradd rnpuser
-RUN echo -e "rnpuser\tALL=(ALL)\tNOPASSWD:\tALL" > /etc/sudoers.d/rnpuser
-RUN echo -e "rnpuser\tsoft\tnproc\tunlimited\n" > /etc/security/limits.d/30-rnpuser.conf
-
-# Everything below wouldn't be needed if packaged gpg didn't fail with "Unknown elliptic curve"
-# on these tests from cli_tests.Misc:
-# test_aead_last_chunk_zero_length
-# test_clearsign_long_lines
-# test_eddsa_sig_lead_zero
-# test_text_sig_crcr
-
-COPY ci ci
-RUN export USE_STATIC_DEPENDENCIES=yes && su rnpuser -c ci/install_noncacheable_dependencies.sh
-RUN export USE_STATIC_DEPENDENCIES=yes && su rnpuser -c ci/install_cacheable_dependencies.sh
-RUN rm -rf /home/rnpuser/local-builds
diff --git a/ci/docker/fedora35.test-locally b/ci/docker/fedora35.test-locally
deleted file mode 100755
index 892c9a6..0000000
--- a/ci/docker/fedora35.test-locally
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/bash
-
-rm -rf /tmp/rnp*
-
-cat > run-this <<EOF
-#!/bin/bash
-set -e
-set -x
-
-export USE_STATIC_DEPENDENCIES=no
-
-export BUILD_MODE=normal CC=gcc CXX=g++ CRYPTO_BACKEND=openssl
-#export BUILD_MODE=sanitize CC=clang CXX=clang++ CRYPTO_BACKEND=botan
-
-cp -a /rnp /rnp.container
-cd /rnp.container
-chown -R rnpuser:rnpuser .
-su rnpuser -c ci/run.sh || bash -i
-EOF
-chmod a+x run-this
-
-docker run -v $PWD:/rnp -it andreyutkin/rnp-ci-fedora:35 /rnp/run-this
diff --git a/ci/tests/ci-tests.sh b/ci/tests/ci-tests.sh
index 1aaba03..73c724d 100755
--- a/ci/tests/ci-tests.sh
+++ b/ci/tests/ci-tests.sh
@@ -106,7 +106,7 @@ test_supported_features() {
;;
*)
so_folder="lib64"
- botan_only+=("${brainpool[@]}")
+# botan_only+=("${brainpool[@]}")
esac
if [[ "${CRYPTO_BACKEND:-}" == "openssl" ]]; then
@@ -118,9 +118,9 @@ test_supported_features() {
fi
if [[ "$OSTYPE" == darwin* ]]; then
- export DYLD_LIBRARY_PATH="$library_path"
+ export DYLD_LIBRARY_PATH="$library_path${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}"
else
- export LD_LIBRARY_PATH="$library_path"
+ export LD_LIBRARY_PATH="$library_path${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}"
fi
"$RNP_INSTALL"/bin/rnp --version > rnp-version
diff --git a/ci/tests/deb-tests.sh b/ci/tests/deb-tests.sh
index 7805702..3563022 100755
--- a/ci/tests/deb-tests.sh
+++ b/ci/tests/deb-tests.sh
@@ -43,8 +43,6 @@ declare expected_libraries=(
declare expected_devlibraries=(
"$DIR_LIB/librnp.so"
- "$DIR_LIB/librnp.a"
- "$DIR_LIB/libsexp.a"
"$DIR_LIB/pkgconfig/librnp.pc"
)
diff --git a/ci/tests/pk-tests.sh b/ci/tests/pk-tests.sh
index 2b22df9..cd496b4 100755
--- a/ci/tests/pk-tests.sh
+++ b/ci/tests/pk-tests.sh
@@ -63,8 +63,8 @@ create_cmake_file() {
set_target_properties(JSON-C::JSON-C PROPERTIES INTERFACE_LINK_LIBRARIES PkgConfig::JSONC)
pkg_check_modules(Botan REQUIRED IMPORTED_TARGET botan-2)
- add_library(Botan2::Botan2 INTERFACE IMPORTED)
- set_target_properties(Botan2::Botan2 PROPERTIES INTERFACE_LINK_LIBRARIES PkgConfig::Botan)
+ add_library(Botan::Botan INTERFACE IMPORTED)
+ set_target_properties(Botan::Botan PROPERTIES INTERFACE_LINK_LIBRARIES PkgConfig::Botan)
find_package(rnp REQUIRED)
@@ -101,33 +101,6 @@ test_shared_library() {
sudo yum -y erase $(rpm -qa | grep rnp)
}
-test_static_library() {
- sudo yum -y localinstall librnp0-0*.*.rpm librnp0-devel-0*.*.rpm
- pushd "$(mktemp -d)"
- create_source_file
- create_cmake_file 'rnp::librnp-static'
-
-# shellcheck disable=SC2251
-! cmake . -DCMAKE_MODULE_PATH="$DIR_CMAKE"/*
- assertEquals "cmake failed at static library test" 0 "${PIPESTATUS[0]}"
-
-# shellcheck disable=SC2251
-! make
- assertEquals "make failed at static library test" 0 "${PIPESTATUS[0]}"
-
-# shellcheck disable=SC2251
-! ./find_package_test
- assertEquals "test program failed at static library test" 0 "${PIPESTATUS[0]}"
-
-# shellcheck disable=SC2251
-! ldd find_package_test | grep librnp
- assertNotEquals "unexpected reference to shared rnp library at static library test" 0 "${PIPESTATUS[1]}"
-
- popd
-# shellcheck disable=SC2046
- sudo yum -y erase $(rpm -qa | grep rnp)
-}
-
test_no_library() {
pushd "$(mktemp -d)"
create_source_file
diff --git a/ci/tests/pkg-tests.sh b/ci/tests/pkg-tests.sh
index dbeaac6..dcc4d01 100755
--- a/ci/tests/pkg-tests.sh
+++ b/ci/tests/pkg-tests.sh
@@ -43,8 +43,6 @@ declare expected_libraries=(
declare expected_devlibraries=(
"$DIR_LIB/librnp.so"
- "$DIR_LIB/librnp.a"
- "$DIR_LIB/libsexp.a"
"$DIR_LIB/pkgconfig/librnp.pc"
)
diff --git a/ci/tests/rpm-tests.sh b/ci/tests/rpm-tests.sh
index 39f8dd0..75b676e 100755
--- a/ci/tests/rpm-tests.sh
+++ b/ci/tests/rpm-tests.sh
@@ -50,8 +50,6 @@ declare expected_libraries=(
declare expected_devlibraries=(
"$DIR_LIB/librnp.so"
- "$DIR_LIB/librnp.a"
- "$DIR_LIB/libsexp.a"
"$DIR_LIB/pkgconfig/librnp.pc"
)