summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:32:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:32:50 +0000
commitc617178f9517a33ea878066e13e8836f91574e1d (patch)
treeed4e79104cbba5bea8ec7d1e72540646598dc504 /debian/rules
parentAdding upstream version 0.17.0. (diff)
downloadrnp-debian/0.17.0-3.tar.xz
rnp-debian/0.17.0-3.zip
Adding debian version 0.17.0-3.debian/0.17.0-3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..63b7dd8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+export DEB_VERSION
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CXXFLAGS_MAINT_APPEND = -DS2K_MINIMUM_TUNING_RATIO=4
+
+ifneq (,$(filter $(DEB_HOST_ARCH), s390x))
+export DEB_CXXFLAGS_MAINT_APPEND = -DS2K_MINIMUM_TUNING_RATIO=1.5
+endif
+
+CONFIGURE_OPTIONS = -DBUILD_SHARED_LIBS=on \
+ -DDOWNLOAD_GTEST=off \
+ -DGTEST_SOURCES=/usr/src/googletest \
+ -DSYSTEM_LIBSEXPP=on \
+ -DDOWNLOAD_RUBYRNP=off
+
+ifneq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+CONFIGURE_OPTIONS += -DBUILD_TESTING=off
+endif
+
+ifneq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
+CONFIGURE_OPTIONS += -DENABLE_DOC=off
+else
+CONFIGURE_OPTIONS += -DENABLE_DOC=on
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure --builddirectory=build -- $(CONFIGURE_OPTIONS)
+
+%:
+ dh $@ --builddirectory=build