summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:32:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:32:49 +0000
commit8053187731ae8e3eb368d8360989cf5fd6eed9f7 (patch)
tree32bada84ff5d7460cdf3934fcbdbe770d6afe4cd /flake.nix
parentInitial commit. (diff)
downloadrnp-8053187731ae8e3eb368d8360989cf5fd6eed9f7.tar.xz
rnp-8053187731ae8e3eb368d8360989cf5fd6eed9f7.zip
Adding upstream version 0.17.0.upstream/0.17.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..c9ddc20
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,26 @@
+{
+ description = "High performance C++ OpenPGP library, fully compliant to RFC 4880";
+
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = nixpkgs.legacyPackages.${system};
+ thePackage = pkgs.callPackage ./default.nix { };
+ in
+ rec {
+ defaultApp = flake-utils.lib.mkApp {
+ drv = defaultPackage;
+ };
+ defaultPackage = thePackage;
+ devShell = pkgs.mkShell {
+ buildInputs = [
+ thePackage
+ ];
+ };
+ });
+} \ No newline at end of file