summaryrefslogtreecommitdiffstats
path: root/contrib/cdb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/cdb/CMakeLists.txt')
-rw-r--r--contrib/cdb/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/contrib/cdb/CMakeLists.txt b/contrib/cdb/CMakeLists.txt
new file mode 100644
index 0000000..6b5b676
--- /dev/null
+++ b/contrib/cdb/CMakeLists.txt
@@ -0,0 +1,8 @@
+# CDB support makefile
+SET(CDBSRC cdb_init.c
+ cdb_find.c
+ cdb_make.c)
+
+ADD_LIBRARY(rspamd-cdb STATIC ${CDBSRC})
+SET_TARGET_PROPERTIES(rspamd-cdb PROPERTIES VERSION ${RSPAMD_VERSION})
+SET_TARGET_PROPERTIES(rspamd-cdb PROPERTIES COMPILE_FLAGS "-DRSPAMD_LIB") \ No newline at end of file