summaryrefslogtreecommitdiffstats
path: root/contrib/http-parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--contrib/http-parser/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/contrib/http-parser/CMakeLists.txt b/contrib/http-parser/CMakeLists.txt
new file mode 100644
index 0000000..a5da701
--- /dev/null
+++ b/contrib/http-parser/CMakeLists.txt
@@ -0,0 +1,8 @@
+SET(HTTPSRC http_parser.c)
+
+
+SET(HTTP_COMPILE_FLAGS "-DRSPAMD_LIB")
+
+ADD_LIBRARY(rspamd-http-parser STATIC ${HTTPSRC})
+SET_TARGET_PROPERTIES(rspamd-http-parser PROPERTIES VERSION ${RSPAMD_VERSION})
+SET_TARGET_PROPERTIES(rspamd-http-parser PROPERTIES COMPILE_FLAGS "${HTTP_COMPILE_FLAGS}") \ No newline at end of file