summaryrefslogtreecommitdiffstats
path: root/contrib/improg/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:28:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:28:20 +0000
commitdcc721a95bef6f0d8e6d8775b8efe33e5aecd562 (patch)
tree66a2774cd0ee294d019efd71d2544c70f42b2842 /contrib/improg/Makefile.am
parentInitial commit. (diff)
downloadrsyslog-dcc721a95bef6f0d8e6d8775b8efe33e5aecd562.tar.xz
rsyslog-dcc721a95bef6f0d8e6d8775b8efe33e5aecd562.zip
Adding upstream version 8.2402.0.upstream/8.2402.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--contrib/improg/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/contrib/improg/Makefile.am b/contrib/improg/Makefile.am
new file mode 100644
index 0000000..3309098
--- /dev/null
+++ b/contrib/improg/Makefile.am
@@ -0,0 +1,11 @@
+pkglib_LTLIBRARIES = improg.la
+
+improg_la_SOURCES = improg.c
+improg_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+improg_la_LDFLAGS = -module -avoid-version
+improg_la_LIBADD =
+
+if ENABLE_LIBLOGGING_STDLOG
+improg_la_CPPFLAGS += $(LIBLOGGING_STDLOG_CFLAGS)
+improg_la_LDFLAGS += $(LIBLOGGING_STDLOG_LIBS)
+endif