summaryrefslogtreecommitdiffstats
path: root/plugins/mmdblookup/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:28:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 16:28:20 +0000
commitdcc721a95bef6f0d8e6d8775b8efe33e5aecd562 (patch)
tree66a2774cd0ee294d019efd71d2544c70f42b2842 /plugins/mmdblookup/Makefile.am
parentInitial commit. (diff)
downloadrsyslog-dcc721a95bef6f0d8e6d8775b8efe33e5aecd562.tar.xz
rsyslog-dcc721a95bef6f0d8e6d8775b8efe33e5aecd562.zip
Adding upstream version 8.2402.0.upstream/8.2402.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--plugins/mmdblookup/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/plugins/mmdblookup/Makefile.am b/plugins/mmdblookup/Makefile.am
new file mode 100644
index 0000000..bb7c156
--- /dev/null
+++ b/plugins/mmdblookup/Makefile.am
@@ -0,0 +1,14 @@
+pkglib_LTLIBRARIES = mmdblookup.la
+
+if MMDBLOOKUP_USE_DUMMY
+mmdblookup_la_SOURCES = dummy.c
+mmdblookup_la_LDFLAGS = -module -avoid-version
+else
+mmdblookup_la_SOURCES = mmdblookup.c
+mmdblookup_la_LDFLAGS = -module -avoid-version -lmaxminddb
+endif
+
+mmdblookup_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
+mmdblookup_la_LIBADD =
+
+EXTRA_DIST =