summaryrefslogtreecommitdiffstats
path: root/plugins/imtcp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/imtcp/Makefile.am')
-rw-r--r--plugins/imtcp/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/plugins/imtcp/Makefile.am b/plugins/imtcp/Makefile.am
new file mode 100644
index 0000000..f2ab10f
--- /dev/null
+++ b/plugins/imtcp/Makefile.am
@@ -0,0 +1,11 @@
+pkglib_LTLIBRARIES = imtcp.la
+
+imtcp_la_SOURCES = imtcp.c
+imtcp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+imtcp_la_LDFLAGS = -module -avoid-version
+imtcp_la_LIBADD =
+
+if ENABLE_LIBLOGGING_STDLOG
+imtcp_la_CPPFLAGS += $(LIBLOGGING_STDLOG_CFLAGS)
+imtcp_la_LDFLAGS += $(LIBLOGGING_STDLOG_LIBS)
+endif