summaryrefslogtreecommitdiffstats
path: root/plugins/imuxsock/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/imuxsock/Makefile.am')
-rw-r--r--plugins/imuxsock/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/plugins/imuxsock/Makefile.am b/plugins/imuxsock/Makefile.am
new file mode 100644
index 0000000..6bf9c20
--- /dev/null
+++ b/plugins/imuxsock/Makefile.am
@@ -0,0 +1,11 @@
+pkglib_LTLIBRARIES = imuxsock.la
+
+imuxsock_la_SOURCES = imuxsock.c
+imuxsock_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+imuxsock_la_LDFLAGS = -module -avoid-version
+imuxsock_la_LIBADD =
+
+if ENABLE_LIBLOGGING_STDLOG
+imuxsock_la_CPPFLAGS += $(LIBLOGGING_STDLOG_CFLAGS)
+imuxsock_la_LDFLAGS += $(LIBLOGGING_STDLOG_LIBS)
+endif