summaryrefslogtreecommitdiffstats
path: root/plugins/mmdblookup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mmdblookup/Makefile.am')
-rw-r--r--plugins/mmdblookup/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/plugins/mmdblookup/Makefile.am b/plugins/mmdblookup/Makefile.am
new file mode 100644
index 0000000..bb7c156
--- /dev/null
+++ b/plugins/mmdblookup/Makefile.am
@@ -0,0 +1,14 @@
+pkglib_LTLIBRARIES = mmdblookup.la
+
+if MMDBLOOKUP_USE_DUMMY
+mmdblookup_la_SOURCES = dummy.c
+mmdblookup_la_LDFLAGS = -module -avoid-version
+else
+mmdblookup_la_SOURCES = mmdblookup.c
+mmdblookup_la_LDFLAGS = -module -avoid-version -lmaxminddb
+endif
+
+mmdblookup_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
+mmdblookup_la_LIBADD =
+
+EXTRA_DIST =