summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/big_endian.patch26
2 files changed, 31 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 273fd29..18f768c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+ruamel.yaml (0.18.6+ds-3) unstable; urgency=medium
+
+ * Team upload
+ * Fix big-endian patch: there is a further point in code where clib
+ is still loaded that has to be skipped on big-endian machines
+
+ -- Julian Gilbey <jdg@debian.org> Thu, 18 Apr 2024 14:17:35 +0100
+
ruamel.yaml (0.18.6+ds-2~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/patches/big_endian.patch b/debian/patches/big_endian.patch
index 4f0afda..c413860 100644
--- a/debian/patches/big_endian.patch
+++ b/debian/patches/big_endian.patch
@@ -13,13 +13,14 @@ Last-Update: 2024-04-18
--- a/__init__.py
+++ b/__init__.py
-@@ -1,4 +1,5 @@
-
+@@ -1,5 +1,6 @@
+
from __future__ import annotations
+import sys
if False: # MYPY
-@@ -47,11 +47,13 @@
+ from typing import Dict, Any # NOQA
+@@ -47,11 +48,13 @@
version_info = _package_data['version_info']
__version__ = _package_data['__version__']
@@ -52,3 +53,22 @@ Last-Update: 2024-04-18
@pytest.mark.skipif( # type: ignore
platform.python_implementation() in ['Jython', 'PyPy'],
+--- a/main.py
++++ b/main.py
+@@ -41,10 +41,12 @@
+ from types import TracebackType
+ from pathlib import Path
+
+-try:
+- from _ruamel_yaml import CParser, CEmitter # type: ignore
+-except: # NOQA
+- CParser = CEmitter = None
++CParser = CEmitter = None
++if sys.byteorder == "little":
++ try:
++ from _ruamel_yaml import CParser, CEmitter # type: ignore
++ except: # NOQA
++ pass
+
+ # import io
+