summaryrefslogtreecommitdiffstats
path: root/src/bindgen/cargo/cargo_lock.rs
diff options
context:
space:
mode:
Diffstat (limited to 'src/bindgen/cargo/cargo_lock.rs')
-rw-r--r--src/bindgen/cargo/cargo_lock.rs51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/bindgen/cargo/cargo_lock.rs b/src/bindgen/cargo/cargo_lock.rs
new file mode 100644
index 0000000..9302082
--- /dev/null
+++ b/src/bindgen/cargo/cargo_lock.rs
@@ -0,0 +1,51 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+use std::fs::File;
+use std::io;
+use std::io::Read;
+use std::path::Path;
+
+#[derive(Debug)]
+/// Possible errors that can occur during Cargo.toml parsing.
+pub enum Error {
+ /// Error during reading of Cargo.toml
+ Io(io::Error),
+ /// Deserialization error
+ Toml(toml::de::Error),
+}
+
+impl From<io::Error> for Error {
+ fn from(err: io::Error) -> Self {
+ Error::Io(err)
+ }
+}
+impl From<toml::de::Error> for Error {
+ fn from(err: toml::de::Error) -> Self {
+ Error::Toml(err)
+ }
+}
+
+#[derive(Clone, Deserialize, Debug)]
+pub struct Lock {
+ pub root: Option<Package>,
+ pub package: Option<Vec<Package>>,
+}
+
+#[derive(Clone, Deserialize, Debug)]
+pub struct Package {
+ pub name: String,
+ pub version: String,
+ /// A list of dependencies formatted like "NAME VERSION-OPT REGISTRY-OPT"
+ pub dependencies: Option<Vec<String>>,
+}
+
+/// Parse the Cargo.toml for a given path
+pub fn lock(manifest_path: &Path) -> Result<Lock, Error> {
+ let mut s = String::new();
+ let mut f = File::open(manifest_path)?;
+ f.read_to_string(&mut s)?;
+
+ toml::from_str::<Lock>(&s).map_err(|x| x.into())
+}