summaryrefslogtreecommitdiffstats
path: root/config.toml.example
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /config.toml.example
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config.toml.example')
-rw-r--r--config.toml.example811
1 files changed, 0 insertions, 811 deletions
diff --git a/config.toml.example b/config.toml.example
deleted file mode 100644
index 69eb228a2..000000000
--- a/config.toml.example
+++ /dev/null
@@ -1,811 +0,0 @@
-# Sample TOML configuration file for building Rust.
-#
-# To configure rustbuild, copy this file to the directory from which you will be
-# running the build, and name it config.toml.
-#
-# All options are commented out by default in this file, and they're commented
-# out with their default values. The build system by default looks for
-# `config.toml` in the current directory of a build for build configuration, but
-# a custom configuration file can also be specified with `--config` to the build
-# system.
-
-# Keeps track of the last version of `x.py` used.
-# If it does not match the version that is currently running,
-# `x.py` will prompt you to update it and read the changelog.
-# See `src/bootstrap/CHANGELOG.md` for more information.
-changelog-seen = 2
-
-# =============================================================================
-# Global Settings
-# =============================================================================
-
-# Use different pre-set defaults than the global defaults.
-#
-# See `src/bootstrap/defaults` for more information.
-# Note that this has no default value (x.py uses the defaults in `config.toml.example`).
-#profile = <none>
-
-# =============================================================================
-# Tweaking how LLVM is compiled
-# =============================================================================
-[llvm]
-
-# Whether to use Rust CI built LLVM instead of locally building it.
-#
-# Unless you're developing for a target where Rust CI doesn't build a compiler
-# toolchain or changing LLVM locally, you probably want to set this to true.
-#
-# All tier 1 targets are currently supported; set this to `"if-available"` if
-# you are not sure whether you're on a tier 1 target.
-#
-# We also currently only support this when building LLVM for the build triple.
-#
-# Note that many of the LLVM options are not currently supported for
-# downloading. Currently only the "assertions" option can be toggled.
-#
-# Defaults to "if-available" when `channel = "dev"` and "false" otherwise.
-#download-ci-llvm = "if-available"
-
-# Indicates whether LLVM rebuild should be skipped when running bootstrap. If
-# this is `false` then the compiler's LLVM will be rebuilt whenever the built
-# version doesn't have the correct hash. If it is `true` then LLVM will never
-# be rebuilt. The default value is `false`.
-#skip-rebuild = false
-
-# Indicates whether the LLVM build is a Release or Debug build
-#optimize = true
-
-# Indicates whether LLVM should be built with ThinLTO. Note that this will
-# only succeed if you use clang, lld, llvm-ar, and llvm-ranlib in your C/C++
-# toolchain (see the `cc`, `cxx`, `linker`, `ar`, and `ranlib` options below).
-# More info at: https://clang.llvm.org/docs/ThinLTO.html#clang-bootstrap
-#thin-lto = false
-
-# Indicates whether an LLVM Release build should include debug info
-#release-debuginfo = false
-
-# Indicates whether the LLVM assertions are enabled or not
-#assertions = false
-
-# Indicates whether the LLVM testsuite is enabled in the build or not. Does
-# not execute the tests as part of the build as part of x.py build et al,
-# just makes it possible to do `ninja check-llvm` in the staged LLVM build
-# directory when doing LLVM development as part of Rust development.
-#tests = false
-
-# Indicates whether the LLVM plugin is enabled or not
-#plugins = false
-
-# Indicates whether ccache is used when building LLVM
-#ccache = false
-# or alternatively ...
-#ccache = "/path/to/ccache"
-
-# If an external LLVM root is specified, we automatically check the version by
-# default to make sure it's within the range that we're expecting, but setting
-# this flag will indicate that this version check should not be done.
-#version-check = true
-
-# When true, link libstdc++ statically into the rustc_llvm.
-# This is useful if you don't want to use the dynamic version of that
-# library provided by LLVM.
-#static-libstdcpp = false
-
-# Whether to use Ninja to build LLVM. This runs much faster than make.
-#ninja = true
-
-# LLVM targets to build support for.
-# Note: this is NOT related to Rust compilation targets. However, as Rust is
-# dependent on LLVM for code generation, turning targets off here WILL lead to
-# the resulting rustc being unable to compile for the disabled architectures.
-# Also worth pointing out is that, in case support for new targets are added to
-# LLVM, enabling them here doesn't mean Rust is automatically gaining said
-# support. You'll need to write a target specification at least, and most
-# likely, teach rustc about the C ABI of the target. Get in touch with the
-# Rust team and file an issue if you need assistance in porting!
-#targets = "AArch64;ARM;BPF;Hexagon;MSP430;Mips;NVPTX;PowerPC;RISCV;Sparc;SystemZ;WebAssembly;X86"
-
-# LLVM experimental targets to build support for. These targets are specified in
-# the same format as above, but since these targets are experimental, they are
-# not built by default and the experimental Rust compilation targets that depend
-# on them will not work unless the user opts in to building them.
-#experimental-targets = "AVR;M68k"
-
-# Cap the number of parallel linker invocations when compiling LLVM.
-# This can be useful when building LLVM with debug info, which significantly
-# increases the size of binaries and consequently the memory required by
-# each linker process.
-# If absent or 0, linker invocations are treated like any other job and
-# controlled by rustbuild's -j parameter.
-#link-jobs = 0
-
-# When invoking `llvm-config` this configures whether the `--shared` argument is
-# passed to prefer linking to shared libraries.
-# NOTE: `thin-lto = true` requires this to be `true` and will give an error otherwise.
-#link-shared = false
-
-# When building llvm, this configures what is being appended to the version.
-# The default is "-rust-$version-$channel", except for dev channel where rustc
-# version number is omitted. To use LLVM version as is, provide an empty string.
-#version-suffix = "-rust-dev"
-
-# On MSVC you can compile LLVM with clang-cl, but the test suite doesn't pass
-# with clang-cl, so this is special in that it only compiles LLVM with clang-cl.
-# Note that this takes a /path/to/clang-cl, not a boolean.
-#clang-cl = cc
-
-# Pass extra compiler and linker flags to the LLVM CMake build.
-#cflags = ""
-#cxxflags = ""
-#ldflags = ""
-
-# Use libc++ when building LLVM instead of libstdc++. This is the default on
-# platforms already use libc++ as the default C++ library, but this option
-# allows you to use libc++ even on platforms when it's not. You need to ensure
-# that your host compiler ships with libc++.
-#use-libcxx = false
-
-# The value specified here will be passed as `-DLLVM_USE_LINKER` to CMake.
-#use-linker = <none> (path)
-
-# Whether or not to specify `-DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=YES`
-#allow-old-toolchain = false
-
-# Whether to include the Polly optimizer.
-#polly = false
-
-# Whether to build the clang compiler.
-#clang = false
-
-# Custom CMake defines to set when building LLVM.
-#build-config = {}
-
-# =============================================================================
-# General build configuration options
-# =============================================================================
-[build]
-# The default stage to use for the `check` subcommand
-#check-stage = 0
-
-# The default stage to use for the `doc` subcommand
-#doc-stage = 0
-
-# The default stage to use for the `build` subcommand
-#build-stage = 1
-
-# The default stage to use for the `test` subcommand
-#test-stage = 1
-
-# The default stage to use for the `dist` subcommand
-#dist-stage = 2
-
-# The default stage to use for the `install` subcommand
-#install-stage = 2
-
-# The default stage to use for the `bench` subcommand
-#bench-stage = 2
-
-# Build triple for the original snapshot compiler. This must be a compiler that
-# nightlies are already produced for. The current platform must be able to run
-# binaries of this build triple and the nightly will be used to bootstrap the
-# first compiler.
-#
-# Defaults to platform where `x.py` is run.
-#build = "x86_64-unknown-linux-gnu" (as an example)
-
-# Which triples to produce a compiler toolchain for. Each of these triples will
-# be bootstrapped from the build triple themselves.
-#
-# Defaults to just the build triple.
-#host = ["x86_64-unknown-linux-gnu"] (as an example)
-
-# Which triples to build libraries (core/alloc/std/test/proc_macro) for. Each of
-# these triples will be bootstrapped from the build triple themselves.
-#
-# Defaults to `host`. If you set this explicitly, you likely want to add all
-# host triples to this list as well in order for those host toolchains to be
-# able to compile programs for their native target.
-#target = ["x86_64-unknown-linux-gnu"] (as an example)
-
-# Use this directory to store build artifacts.
-# You can use "$ROOT" to indicate the root of the git repository.
-#build-dir = "build"
-
-# Instead of downloading the src/stage0.json version of Cargo specified, use
-# this Cargo binary instead to build all Rust code
-#cargo = "/path/to/cargo"
-
-# Instead of downloading the src/stage0.json version of the compiler
-# specified, use this rustc binary instead as the stage0 snapshot compiler.
-#rustc = "/path/to/rustc"
-
-# Instead of download the src/stage0.json version of rustfmt specified,
-# use this rustfmt binary instead as the stage0 snapshot rustfmt.
-#rustfmt = "/path/to/rustfmt"
-
-# Flag to specify whether any documentation is built. If false, rustdoc and
-# friends will still be compiled but they will not be used to generate any
-# documentation.
-#docs = true
-
-# Flag to specify whether CSS, JavaScript, and HTML are minified when
-# docs are generated. JSON is always minified, because it's enormous,
-# and generated in already-minified form from the beginning.
-#docs-minification = true
-
-# Flag to specify whether private items should be included in the library docs.
-#library-docs-private-items = false
-
-# Indicate whether the compiler should be documented in addition to the standard
-# library and facade crates.
-#compiler-docs = false
-
-# Indicate whether git submodules are managed and updated automatically.
-#submodules = true
-
-# The path to (or name of) the GDB executable to use. This is only used for
-# executing the debuginfo test suite.
-#gdb = "gdb"
-
-# The node.js executable to use. Note that this is only used for the emscripten
-# target when running tests, otherwise this can be omitted.
-#nodejs = "node"
-
-# Python interpreter to use for various tasks throughout the build, notably
-# rustdoc tests, the lldb python interpreter, and some dist bits and pieces.
-#
-# Defaults to the Python interpreter used to execute x.py
-#python = "python"
-
-# The path to the REUSE executable to use. Note that REUSE is not required in
-# most cases, as our tooling relies on a cached (and shrinked) copy of the
-# REUSE output present in the git repository and in our source tarballs.
-#
-# REUSE is only needed if your changes caused the overral licensing of the
-# repository to change, and the cached copy has to be regenerated.
-#
-# Defaults to the "reuse" command in the system path.
-#reuse = "reuse"
-
-# Force Cargo to check that Cargo.lock describes the precise dependency
-# set that all the Cargo.toml files create, instead of updating it.
-#locked-deps = false
-
-# Indicate whether the vendored sources are used for Rust dependencies or not
-#vendor = false
-
-# Typically the build system will build the Rust compiler twice. The second
-# compiler, however, will simply use its own libraries to link against. If you
-# would rather to perform a full bootstrap, compiling the compiler three times,
-# then you can set this option to true. You shouldn't ever need to set this
-# option to true.
-#full-bootstrap = false
-
-# Enable a build of the extended Rust tool set which is not only the compiler
-# but also tools such as Cargo. This will also produce "combined installers"
-# which are used to install Rust and Cargo together. This is disabled by
-# default. The `tools` option (immediately below) specifies which tools should
-# be built if `extended = true`.
-#extended = false
-
-# Set of tools to be included in the installation.
-#
-# If `extended = false`, the only one of these built by default is rustdoc.
-#
-# If `extended = true`, they're all included, with the exception of
-# rust-demangler which additionally requires `profiler = true` to be set.
-#
-# If any enabled tool fails to build, the installation fails.
-#tools = [
-# "cargo",
-# "clippy",
-# "rustdoc",
-# "rustfmt",
-# "rust-analyzer",
-# "analysis",
-# "src",
-# "rust-demangler", # if profiler = true
-#]
-
-# Verbosity level: 0 == not verbose, 1 == verbose, 2 == very verbose
-#verbose = 0
-
-# Build the sanitizer runtimes
-#sanitizers = false
-
-# Build the profiler runtime (required when compiling with options that depend
-# on this runtime, such as `-C profile-generate` or `-C instrument-coverage`).
-#profiler = false
-
-# Indicates whether the native libraries linked into Cargo will be statically
-# linked or not.
-#cargo-native-static = false
-
-# Run the build with low priority, by setting the process group's "nice" value
-# to +10 on Unix platforms, and by using a "low priority" job object on Windows.
-#low-priority = false
-
-# Arguments passed to the `./configure` script, used during distcheck. You
-# probably won't fill this in but rather it's filled in by the `./configure`
-# script.
-#configure-args = []
-
-# Indicates that a local rebuild is occurring instead of a full bootstrap,
-# essentially skipping stage0 as the local compiler is recompiling itself again.
-#local-rebuild = false
-
-# Print out how long each rustbuild step took (mostly intended for CI and
-# tracking over time)
-#print-step-timings = false
-
-# Print out resource usage data for each rustbuild step, as defined by the Unix
-# struct rusage. (Note that this setting is completely unstable: the data it
-# captures, what platforms it supports, the format of its associated output, and
-# this setting's very existence, are all subject to change.)
-#print-step-rusage = false
-
-# Always patch binaries for usage with Nix toolchains. If `true` then binaries
-# will be patched unconditionally. If `false` or unset, binaries will be patched
-# only if the current distribution is NixOS. This option is useful when using
-# a Nix toolchain on non-NixOS distributions.
-#patch-binaries-for-nix = false
-
-# Collect information and statistics about the current build and writes it to
-# disk. Enabling this or not has no impact on the resulting build output. The
-# schema of the file generated by the build metrics feature is unstable, and
-# this is not intended to be used during local development.
-#metrics = false
-
-# =============================================================================
-# General install configuration options
-# =============================================================================
-[install]
-
-# Instead of installing to /usr/local, install to this path instead.
-#prefix = "/usr/local"
-
-# Where to install system configuration files
-# If this is a relative path, it will get installed in `prefix` above
-#sysconfdir = "/etc"
-
-# Where to install documentation in `prefix` above
-#docdir = "share/doc/rust"
-
-# Where to install binaries in `prefix` above
-#bindir = "bin"
-
-# Where to install libraries in `prefix` above
-#libdir = "lib"
-
-# Where to install man pages in `prefix` above
-#mandir = "share/man"
-
-# Where to install data in `prefix` above
-#datadir = "share"
-
-# =============================================================================
-# Options for compiling Rust code itself
-# =============================================================================
-[rust]
-
-# Whether or not to optimize the compiler and standard library.
-# WARNING: Building with optimize = false is NOT SUPPORTED. Due to bootstrapping,
-# building without optimizations takes much longer than optimizing. Further, some platforms
-# fail to build without this optimization (c.f. #65352).
-#optimize = true
-
-# Indicates that the build should be configured for debugging Rust. A
-# `debug`-enabled compiler and standard library will be somewhat
-# slower (due to e.g. checking of debug assertions) but should remain
-# usable.
-#
-# Note: If this value is set to `true`, it will affect a number of
-# configuration options below as well, if they have been left
-# unconfigured in this file.
-#
-# Note: changes to the `debug` setting do *not* affect `optimize`
-# above. In theory, a "maximally debuggable" environment would
-# set `optimize` to `false` above to assist the introspection
-# facilities of debuggers like lldb and gdb. To recreate such an
-# environment, explicitly set `optimize` to `false` and `debug`
-# to `true`. In practice, everyone leaves `optimize` set to
-# `true`, because an unoptimized rustc with debugging
-# enabled becomes *unusably slow* (e.g. rust-lang/rust#24840
-# reported a 25x slowdown) and bootstrapping the supposed
-# "maximally debuggable" environment (notably libstd) takes
-# hours to build.
-#
-#debug = false
-
-# Whether to download the stage 1 and 2 compilers from CI.
-# This is mostly useful for tools; if you have changes to `compiler/` they will be ignored.
-#
-# You can set this to "if-unchanged" to only download if `compiler/` has not been modified.
-#download-rustc = false
-
-# Number of codegen units to use for each compiler invocation. A value of 0
-# means "the number of cores on this machine", and 1+ is passed through to the
-# compiler.
-#
-# Uses the rustc defaults: https://doc.rust-lang.org/rustc/codegen-options/index.html#codegen-units
-#codegen-units = if incremental { 256 } else { 16 }
-
-# Sets the number of codegen units to build the standard library with,
-# regardless of what the codegen-unit setting for the rest of the compiler is.
-# NOTE: building with anything other than 1 is known to occasionally have bugs.
-# See https://github.com/rust-lang/rust/issues/83600.
-#codegen-units-std = codegen-units
-
-# Whether or not debug assertions are enabled for the compiler and standard
-# library. Debug assertions control the maximum log level used by rustc. When
-# enabled calls to `trace!` and `debug!` macros are preserved in the compiled
-# binary, otherwise they are omitted.
-#
-# Defaults to rust.debug value
-#debug-assertions = rust.debug (boolean)
-
-# Whether or not debug assertions are enabled for the standard library.
-# Overrides the `debug-assertions` option, if defined.
-#
-# Defaults to rust.debug-assertions value
-#debug-assertions-std = rust.debug-assertions (boolean)
-
-# Whether or not to leave debug! and trace! calls in the rust binary.
-# Overrides the `debug-assertions` option, if defined.
-#
-# Defaults to rust.debug-assertions value
-#
-# If you see a message from `tracing` saying
-# `max_level_info` is enabled and means logging won't be shown,
-# set this value to `true`.
-#debug-logging = rust.debug-assertions (boolean)
-
-# Whether or not overflow checks are enabled for the compiler and standard
-# library.
-#
-# Defaults to rust.debug value
-#overflow-checks = rust.debug (boolean)
-
-# Whether or not overflow checks are enabled for the standard library.
-# Overrides the `overflow-checks` option, if defined.
-#
-# Defaults to rust.overflow-checks value
-#overflow-checks-std = rust.overflow-checks (boolean)
-
-# Debuginfo level for most of Rust code, corresponds to the `-C debuginfo=N` option of `rustc`.
-# `0` - no debug info
-# `1` - line tables only - sufficient to generate backtraces that include line
-# information and inlined functions, set breakpoints at source code
-# locations, and step through execution in a debugger.
-# `2` - full debug info with variable and type information
-# Can be overridden for specific subsets of Rust code (rustc, std or tools).
-# Debuginfo for tests run with compiletest is not controlled by this option
-# and needs to be enabled separately with `debuginfo-level-tests`.
-#
-# Note that debuginfo-level = 2 generates several gigabytes of debuginfo
-# and will slow down the linking process significantly.
-#
-# Defaults to 1 if debug is true
-#debuginfo-level = 0
-
-# Debuginfo level for the compiler.
-#debuginfo-level-rustc = debuginfo-level
-
-# Debuginfo level for the standard library.
-#debuginfo-level-std = debuginfo-level
-
-# Debuginfo level for the tools.
-#debuginfo-level-tools = debuginfo-level
-
-# Debuginfo level for the test suites run with compiletest.
-# FIXME(#61117): Some tests fail when this option is enabled.
-#debuginfo-level-tests = 0
-
-# Should rustc be build with split debuginfo? Default is platform dependent.
-# Valid values are the same as those accepted by `-C split-debuginfo`
-# (`off`/`unpacked`/`packed`).
-#
-# On Linux, split debuginfo is disabled by default.
-#
-# On Apple platforms, unpacked split debuginfo is used by default. Unpacked
-# debuginfo does not run `dsymutil`, which packages debuginfo from disparate
-# object files into a single `.dSYM` file. `dsymutil` adds time to builds for
-# no clear benefit, and also makes it more difficult for debuggers to find
-# debug info. The compiler currently defaults to running `dsymutil` to preserve
-# its historical default, but when compiling the compiler itself, we skip it by
-# default since we know it's safe to do so in that case.
-#
-# On Windows platforms, packed debuginfo is the only supported option,
-# producing a `.pdb` file.
-#split-debuginfo = if linux { off } else if windows { packed } else if apple { unpacked }
-
-# Whether or not `panic!`s generate backtraces (RUST_BACKTRACE)
-#backtrace = true
-
-# Whether to always use incremental compilation when building rustc
-#incremental = false
-
-# Build a multi-threaded rustc
-# FIXME(#75760): Some UI tests fail when this option is enabled.
-#parallel-compiler = false
-
-# The default linker that will be hard-coded into the generated
-# compiler for targets that don't specify a default linker explicitly
-# in their target specifications. Note that this is not the linker
-# used to link said compiler. It can also be set per-target (via the
-# `[target.<triple>]` block), which may be useful in a cross-compilation
-# setting.
-#
-# See https://doc.rust-lang.org/rustc/codegen-options/index.html#linker for more information.
-#default-linker = <none> (path)
-
-# The "channel" for the Rust build to produce. The stable/beta channels only
-# allow using stable features, whereas the nightly and dev channels allow using
-# nightly features
-#channel = "dev"
-
-# A descriptive string to be appended to `rustc --version` output, which is
-# also used in places like debuginfo `DW_AT_producer`. This may be useful for
-# supplementary build information, like distro-specific package versions.
-#
-# The Rust compiler will differentiate between versions of itself, including
-# based on this string, which means that if you wish to be compatible with
-# upstream Rust you need to set this to "". However, note that if you are not
-# actually compatible -- for example if you've backported patches that change
-# behavior -- this may lead to miscompilations or other bugs.
-#description = <none> (string)
-
-# The root location of the musl installation directory. The library directory
-# will also need to contain libunwind.a for an unwinding implementation. Note
-# that this option only makes sense for musl targets that produce statically
-# linked binaries.
-#
-# Defaults to /usr on musl hosts. Has no default otherwise.
-#musl-root = <platform specific> (path)
-
-# By default the `rustc` executable is built with `-Wl,-rpath` flags on Unix
-# platforms to ensure that the compiler is usable by default from the build
-# directory (as it links to a number of dynamic libraries). This may not be
-# desired in distributions, for example.
-#rpath = true
-
-# Prints each test name as it is executed, to help debug issues in the test harness itself.
-#verbose-tests = false
-
-# Flag indicating whether tests are compiled with optimizations (the -O flag).
-#optimize-tests = true
-
-# Flag indicating whether codegen tests will be run or not. If you get an error
-# saying that the FileCheck executable is missing, you may want to disable this.
-# Also see the target's llvm-filecheck option.
-#codegen-tests = true
-
-# Flag indicating whether git info will be retrieved from .git automatically.
-# Having the git information can cause a lot of rebuilds during development.
-# Note: If this attribute is not explicitly set (e.g. if left commented out) it
-# will default to true if channel = "dev", but will default to false otherwise.
-#ignore-git = if channel == "dev" { true } else { false }
-
-# When creating source tarballs whether or not to create a source tarball.
-#dist-src = true
-
-# After building or testing extended tools (e.g. clippy and rustfmt), append the
-# result (broken, compiling, testing) into this JSON file.
-#save-toolstates = <none> (path)
-
-# This is an array of the codegen backends that will be compiled for the rustc
-# that's being compiled. The default is to only build the LLVM codegen backend,
-# and currently the only standard options supported are `"llvm"`, `"cranelift"`
-# and `"gcc"`. The first backend in this list will be used as default by rustc
-# when no explicit backend is specified.
-#codegen-backends = ["llvm"]
-
-# Indicates whether LLD will be compiled and made available in the sysroot for
-# rustc to execute.
-#lld = false
-
-# Indicates whether LLD will be used to link Rust crates during bootstrap on
-# supported platforms. The LLD from the bootstrap distribution will be used
-# and not the LLD compiled during the bootstrap.
-#
-# LLD will not be used if we're cross linking.
-#
-# Explicitly setting the linker for a target will override this option when targeting MSVC.
-#use-lld = false
-
-# Indicates whether some LLVM tools, like llvm-objdump, will be made available in the
-# sysroot.
-#llvm-tools = false
-
-# Whether to deny warnings in crates
-#deny-warnings = true
-
-# Print backtrace on internal compiler errors during bootstrap
-#backtrace-on-ice = false
-
-# Whether to verify generated LLVM IR
-#verify-llvm-ir = false
-
-# Compile the compiler with a non-default ThinLTO import limit. This import
-# limit controls the maximum size of functions imported by ThinLTO. Decreasing
-# will make code compile faster at the expense of lower runtime performance.
-#thin-lto-import-instr-limit = if incremental { 10 } else { LLVM default (currently 100) }
-
-# Map debuginfo paths to `/rust/$sha/...`, generally only set for releases
-#remap-debuginfo = false
-
-# Link the compiler against `jemalloc`, where on Linux and OSX it should
-# override the default allocator for rustc and LLVM.
-#jemalloc = false
-
-# Run tests in various test suites with the "nll compare mode" in addition to
-# running the tests in normal mode. Largely only used on CI and during local
-# development of NLL
-#test-compare-mode = false
-
-# Global default for llvm-libunwind for all targets. See the target-specific
-# documentation for llvm-libunwind below. Note that the target-specific
-# option will override this if set.
-#llvm-libunwind = 'no'
-
-# Enable Windows Control Flow Guard checks in the standard library.
-# This only applies from stage 1 onwards, and only for Windows targets.
-#control-flow-guard = false
-
-# Enable symbol-mangling-version v0. This can be helpful when profiling rustc,
-# as generics will be preserved in symbols (rather than erased into opaque T).
-# When no setting is given, the new scheme will be used when compiling the
-# compiler and its tools and the legacy scheme will be used when compiling the
-# standard library.
-# If an explicit setting is given, it will be used for all parts of the codebase.
-#new-symbol-mangling = true|false (see comment)
-
-# Select LTO mode that will be used for compiling rustc. By default, thin local LTO
-# (LTO within a single crate) is used (like for any Rust crate). You can also select
-# "thin" or "fat" to apply Thin/Fat LTO to the `rustc_driver` dylib, or "off" to disable
-# LTO entirely.
-#lto = "thin-local"
-
-# Build compiler with the optimization enabled and -Zvalidate-mir, currently only for `std`
-#validate-mir-opts = 3
-
-# =============================================================================
-# Options for specific targets
-#
-# Each of the following options is scoped to the specific target triple in
-# question and is used for determining how to compile each target.
-# =============================================================================
-[target.x86_64-unknown-linux-gnu]
-
-# C compiler to be used to compile C code. Note that the
-# default value is platform specific, and if not specified it may also depend on
-# what platform is crossing to what platform.
-# See `src/bootstrap/cc_detect.rs` for details.
-#cc = "cc" (path)
-
-# C++ compiler to be used to compile C++ code (e.g. LLVM and our LLVM shims).
-# This is only used for host targets.
-# See `src/bootstrap/cc_detect.rs` for details.
-#cxx = "c++" (path)
-
-# Archiver to be used to assemble static libraries compiled from C/C++ code.
-# Note: an absolute path should be used, otherwise LLVM build will break.
-#ar = "ar" (path)
-
-# Ranlib to be used to assemble static libraries compiled from C/C++ code.
-# Note: an absolute path should be used, otherwise LLVM build will break.
-#ranlib = "ranlib" (path)
-
-# Linker to be used to bootstrap Rust code. Note that the
-# default value is platform specific, and if not specified it may also depend on
-# what platform is crossing to what platform.
-# Setting this will override the `use-lld` option for Rust code when targeting MSVC.
-#linker = "cc" (path)
-
-# Path to the `llvm-config` binary of the installation of a custom LLVM to link
-# against. Note that if this is specified we don't compile LLVM at all for this
-# target.
-#llvm-config = <none> (path)
-
-# Override detection of whether this is a Rust-patched LLVM. This would be used
-# in conjunction with either an llvm-config or build.submodules = false.
-#llvm-has-rust-patches = if llvm-config { false } else { true }
-
-# Normally the build system can find LLVM's FileCheck utility, but if
-# not, you can specify an explicit file name for it.
-#llvm-filecheck = "/path/to/llvm-version/bin/FileCheck"
-
-# Use LLVM libunwind as the implementation for Rust's unwinder.
-# Accepted values are 'in-tree' (formerly true), 'system' or 'no' (formerly false).
-# This option only applies for Linux and Fuchsia targets.
-# On Linux target, if crt-static is not enabled, 'no' means dynamic link to
-# `libgcc_s.so`, 'in-tree' means static link to the in-tree build of llvm libunwind
-# and 'system' means dynamic link to `libunwind.so`. If crt-static is enabled,
-# the behavior is depend on the libc. On musl target, 'no' and 'in-tree' both
-# means static link to the in-tree build of llvm libunwind, and 'system' means
-# static link to `libunwind.a` provided by system. Due to the limitation of glibc,
-# it must link to `libgcc_eh.a` to get a working output, and this option have no effect.
-#llvm-libunwind = 'no' if Linux, 'in-tree' if Fuchsia
-
-# If this target is for Android, this option will be required to specify where
-# the NDK for the target lives. This is used to find the C compiler to link and
-# build native code.
-# See `src/bootstrap/cc_detect.rs` for details.
-#android-ndk = <none> (path)
-
-# Build the sanitizer runtimes for this target.
-# This option will override the same option under [build] section.
-#sanitizers = build.sanitizers (bool)
-
-# Build the profiler runtime for this target(required when compiling with options that depend
-# on this runtime, such as `-C profile-generate` or `-C instrument-coverage`).
-# This option will override the same option under [build] section.
-#profiler = build.profiler (bool)
-
-# Force static or dynamic linkage of the standard library for this target. If
-# this target is a host for rustc, this will also affect the linkage of the
-# compiler itself. This is useful for building rustc on targets that normally
-# only use static libraries. If unset, the target's default linkage is used.
-#crt-static = <platform-specific> (bool)
-
-# The root location of the musl installation directory. The library directory
-# will also need to contain libunwind.a for an unwinding implementation. Note
-# that this option only makes sense for musl targets that produce statically
-# linked binaries.
-#musl-root = build.musl-root (path)
-
-# The full path to the musl libdir.
-#musl-libdir = musl-root/lib
-
-# The root location of the `wasm32-wasi` sysroot. Only used for the
-# `wasm32-wasi` target. If you are building wasm32-wasi target, make sure to
-# create a `[target.wasm32-wasi]` section and move this field there.
-#wasi-root = <none> (path)
-
-# Used in testing for configuring where the QEMU images are located, you
-# probably don't want to use this.
-#qemu-rootfs = <none> (path)
-
-# Skip building the `std` library for this target. Enabled by default for
-# target triples containing `-none`, `nvptx`, `switch`, or `-uefi`.
-#no-std = <platform-specific> (bool)
-
-# =============================================================================
-# Distribution options
-#
-# These options are related to distribution, mostly for the Rust project itself.
-# You probably won't need to concern yourself with any of these options
-# =============================================================================
-[dist]
-
-# This is the folder of artifacts that the build system will sign. All files in
-# this directory will be signed with the default gpg key using the system `gpg`
-# binary. The `asc` and `sha256` files will all be output into the standard dist
-# output folder (currently `build/dist`)
-#
-# This folder should be populated ahead of time before the build system is
-# invoked.
-#sign-folder = <none> (path)
-
-# The remote address that all artifacts will eventually be uploaded to. The
-# build system generates manifests which will point to these urls, and for the
-# manifests to be correct they'll have to have the right URLs encoded.
-#
-# Note that this address should not contain a trailing slash as file names will
-# be appended to it.
-#upload-addr = <none> (URL)
-
-# Whether to build a plain source tarball to upload
-# We disable that on Windows not to override the one already uploaded on S3
-# as the one built on Windows will contain backslashes in paths causing problems
-# on linux
-#src-tarball = true
-
-# Whether to allow failures when building tools
-#missing-tools = false
-
-# List of compression formats to use when generating dist tarballs. The list of
-# formats is provided to rust-installer, which must support all of them.
-#
-# This list must be non-empty.
-#compression-formats = ["gz", "xz"]