summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0005-no-jemalloc.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:49 +0000
commite3cd3a4089ba65c4c74a129653cef5231ccd7572 (patch)
tree793659873c58be8d80c9ac82f23dc35b37002d28 /debian/patches/d-0005-no-jemalloc.patch
parentMerging upstream version 1.69.0+dfsg1. (diff)
downloadrustc-e3cd3a4089ba65c4c74a129653cef5231ccd7572.tar.xz
rustc-e3cd3a4089ba65c4c74a129653cef5231ccd7572.zip
Adding debian version 1.69.0+dfsg1-1.debian/1.69.0+dfsg1-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/d-0005-no-jemalloc.patch')
-rw-r--r--debian/patches/d-0005-no-jemalloc.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/patches/d-0005-no-jemalloc.patch b/debian/patches/d-0005-no-jemalloc.patch
index ac23de8bb..17254fb53 100644
--- a/debian/patches/d-0005-no-jemalloc.patch
+++ b/debian/patches/d-0005-no-jemalloc.patch
@@ -8,10 +8,10 @@ Subject: d-0005-no-jemalloc
2 files changed, 8 deletions(-)
diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
-index 27ee3dd..87fb29f 100644
+index 41003ad..0578f7b 100644
--- a/compiler/rustc/Cargo.toml
+++ b/compiler/rustc/Cargo.toml
-@@ -13,13 +13,7 @@ rustc_codegen_ssa = { path = "../rustc_codegen_ssa" }
+@@ -14,13 +14,7 @@ rustc_codegen_ssa = { path = "../rustc_codegen_ssa" }
# crate is intended to be used by stable MIR consumers, which are not in-tree
rustc_smir = { path = "../rustc_smir" }
@@ -22,14 +22,14 @@ index 27ee3dd..87fb29f 100644
-
[features]
-jemalloc = ['jemalloc-sys']
- llvm = ['rustc_driver/llvm']
- max_level_info = ['rustc_driver/max_level_info']
- rustc_use_parallel_compiler = ['rustc_driver/rustc_use_parallel_compiler']
+ llvm = ['rustc_driver_impl/llvm']
+ max_level_info = ['rustc_driver_impl/max_level_info']
+ rustc_use_parallel_compiler = ['rustc_driver_impl/rustc_use_parallel_compiler']
diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
-index 01d1735..bf0ba06 100644
+index 6273ea5..642fb05 100644
--- a/src/tools/rust-analyzer/crates/profile/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/profile/Cargo.toml
-@@ -15,7 +15,6 @@ cfg-if = "1.0.0"
+@@ -17,7 +17,6 @@ cfg-if = "1.0.0"
libc = "0.2.135"
la-arena = { version = "0.3.0", path = "../../lib/la-arena" }
countme = { version = "3.0.1", features = ["enable"] }
@@ -37,7 +37,7 @@ index 01d1735..bf0ba06 100644
[target.'cfg(target_os = "linux")'.dependencies]
perf-event = "0.4.7"
-@@ -25,7 +24,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
+@@ -27,7 +26,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
[features]
cpu_profiler = []