summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:50:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:50:11 +0000
commit41f4526558b3ce77bfc7a4ac743e39d17b91f2a4 (patch)
treecf3238b3a0ba7664b03012381ad2d3c43709b918 /debian/rules
parentMerging upstream version 1.75.0+dfsg1. (diff)
downloadrustc-41f4526558b3ce77bfc7a4ac743e39d17b91f2a4.tar.xz
rustc-41f4526558b3ce77bfc7a4ac743e39d17b91f2a4.zip
Merging debian version 1.75.0+dfsg1-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index ac5631a87..6610d8ec7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -235,10 +235,10 @@ debian/config.toml: debian/config.toml.in debian/rules
if $(DOWNLOAD_BOOTSTRAP) || [ $(HAVE_BINARY_TARBALL) != 0 ]; \
then sed -i -e '/^rustc = /d' -e '/^cargo = /d' "$@"; fi
# Work around low-memory (32-bit) architectures: https://github.com/rust-lang/rust/issues/45854
-# i386 and x32 fail to mmap rustc_driver when building rustdoc in >1.60
-ifneq (,$(filter $(DEB_BUILD_ARCH), armhf armel i386 mips mipsel powerpc powerpcspe x32))
- sed -i -e 's/^debuginfo-level = .*/debuginfo-level = 0/g' "$@"
-endif
+# otherwise they fail to mmap rustc_driver when building rustdoc in >1.60
+ if [ $(DEB_BUILD_ARCH_BITS) == "32" ]; then \
+ sed -i -e 's/^debuginfo-level = .*/debuginfo-level = 0/g' "$@"; \
+ fi
check-no-old-llvm:
# fail the build if we have any instances of OLD_LLVM_VERSION in debian, except for debian/changelog