summaryrefslogtreecommitdiffstats
path: root/extra/git2/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /extra/git2/debian
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extra/git2/debian')
-rw-r--r--extra/git2/debian/patches/disable-vendor.patch14
-rw-r--r--extra/git2/debian/patches/remove-zlib-ng-compat.patch10
-rw-r--r--extra/git2/debian/patches/series3
-rw-r--r--extra/git2/debian/patches/skip-credential_helper5-if-no-git.patch15
4 files changed, 42 insertions, 0 deletions
diff --git a/extra/git2/debian/patches/disable-vendor.patch b/extra/git2/debian/patches/disable-vendor.patch
new file mode 100644
index 000000000..a4899d8bb
--- /dev/null
+++ b/extra/git2/debian/patches/disable-vendor.patch
@@ -0,0 +1,14 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -70,11 +70,6 @@
+ ssh = ["libgit2-sys/ssh"]
+ ssh_key_from_memory = ["libgit2-sys/ssh_key_from_memory"]
+ unstable = []
+-vendored-libgit2 = ["libgit2-sys/vendored"]
+-vendored-openssl = [
+- "openssl-sys/vendored",
+- "libgit2-sys/vendored-openssl",
+-]
+ zlib-ng-compat = ["libgit2-sys/zlib-ng-compat"]
+
+ [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
diff --git a/extra/git2/debian/patches/remove-zlib-ng-compat.patch b/extra/git2/debian/patches/remove-zlib-ng-compat.patch
new file mode 100644
index 000000000..1ac449c02
--- /dev/null
+++ b/extra/git2/debian/patches/remove-zlib-ng-compat.patch
@@ -0,0 +1,10 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -70,7 +70,6 @@
+ ssh = ["libgit2-sys/ssh"]
+ ssh_key_from_memory = ["libgit2-sys/ssh_key_from_memory"]
+ unstable = []
+-zlib-ng-compat = ["libgit2-sys/zlib-ng-compat"]
+
+ [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
+ version = "0.1"
diff --git a/extra/git2/debian/patches/series b/extra/git2/debian/patches/series
new file mode 100644
index 000000000..5e0e458b2
--- /dev/null
+++ b/extra/git2/debian/patches/series
@@ -0,0 +1,3 @@
+disable-vendor.patch
+remove-zlib-ng-compat.patch
+skip-credential_helper5-if-no-git.patch
diff --git a/extra/git2/debian/patches/skip-credential_helper5-if-no-git.patch b/extra/git2/debian/patches/skip-credential_helper5-if-no-git.patch
new file mode 100644
index 000000000..e5686020c
--- /dev/null
+++ b/extra/git2/debian/patches/skip-credential_helper5-if-no-git.patch
@@ -0,0 +1,15 @@
+Skip the "credential_helper5" test if git is not installled.
+Index: git2/src/cred.rs
+===================================================================
+--- git2.orig/src/cred.rs
++++ git2/src/cred.rs
+@@ -563,6 +563,9 @@ echo username=c
+
+ #[test]
+ fn credential_helper5() {
++ if !Path::new("/usr/bin/git").exists() {
++ return;
++ } //this test does not work if git is not installed
+ if cfg!(windows) {
+ return;
+ } // shell scripts don't work on Windows