summaryrefslogtreecommitdiffstats
path: root/library/backtrace/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /library/backtrace/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'library/backtrace/Cargo.toml')
-rw-r--r--library/backtrace/Cargo.toml22
1 files changed, 12 insertions, 10 deletions
diff --git a/library/backtrace/Cargo.toml b/library/backtrace/Cargo.toml
index ef1c5ec00..477909111 100644
--- a/library/backtrace/Cargo.toml
+++ b/library/backtrace/Cargo.toml
@@ -1,9 +1,9 @@
[package]
name = "backtrace"
-version = "0.3.66"
+version = "0.3.67"
authors = ["The Rust Project Developers"]
build = "build.rs"
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
readme = "README.md"
repository = "https://github.com/rust-lang/backtrace-rs"
homepage = "https://github.com/rust-lang/backtrace-rs"
@@ -35,16 +35,13 @@ serde = { version = "1.0", optional = true, features = ['derive'] }
rustc-serialize = { version = "0.3", optional = true }
# Optionally demangle C++ frames' symbols in backtraces.
-cpp_demangle = { default-features = false, version = "0.3.0", optional = true }
+cpp_demangle = { default-features = false, version = "0.4.0", optional = true, features = ["alloc"] }
-
-# Optional dependencies enabled through the `gimli-symbolize` feature, do not
-# use these features directly.
-addr2line = { version = "0.17.0", default-features = false }
-miniz_oxide = { version = "0.5.0", default-features = false }
+addr2line = { version = "0.19.0", default-features = false }
+miniz_oxide = { version = "0.6.0", default-features = false }
[dependencies.object]
-version = "0.29.0"
+version = "0.30.0"
default-features = false
features = ['read_core', 'elf', 'macho', 'pe', 'unaligned', 'archive']
@@ -61,7 +58,7 @@ dylib-dep = { path = "crates/dylib-dep" }
libloading = "0.7"
[features]
-# By default libstd support and gimli-symbolize is used to symbolize addresses.
+# By default libstd support is enabled.
default = ["std"]
# Include std support. This enables types like `Backtrace`.
@@ -130,3 +127,8 @@ edition = '2018'
name = "concurrent-panics"
required-features = ["std"]
harness = false
+
+[[test]]
+name = "current-exe-mismatch"
+required-features = ["std"]
+harness = false