summaryrefslogtreecommitdiffstats
path: root/src/librustdoc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/librustdoc/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/librustdoc/Cargo.toml')
-rw-r--r--src/librustdoc/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/librustdoc/Cargo.toml b/src/librustdoc/Cargo.toml
new file mode 100644
index 000000000..ddaa7438e
--- /dev/null
+++ b/src/librustdoc/Cargo.toml
@@ -0,0 +1,41 @@
+[package]
+name = "rustdoc"
+version = "0.0.0"
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+arrayvec = { version = "0.7", default-features = false }
+askama = { version = "0.11", default-features = false, features = ["config"] }
+atty = "0.2"
+pulldown-cmark = { version = "0.9.2", default-features = false }
+minifier = "0.2.1"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+smallvec = "1.8.1"
+tempfile = "3"
+itertools = "0.10.1"
+regex = "1"
+rustdoc-json-types = { path = "../rustdoc-json-types" }
+tracing = "0.1"
+tracing-tree = "0.2.0"
+once_cell = "1.10.0"
+
+[dependencies.tracing-subscriber]
+version = "0.3.3"
+default-features = false
+features = ["fmt", "env-filter", "smallvec", "parking_lot", "ansi"]
+
+[target.'cfg(windows)'.dependencies]
+rayon = "1.5.1"
+
+[dev-dependencies]
+expect-test = "1.0"
+
+[features]
+jemalloc = []
+
+[package.metadata.rust-analyzer]
+rustc_private = true