summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile')
-rw-r--r--src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile11
1 files changed, 0 insertions, 11 deletions
diff --git a/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile b/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
deleted file mode 100644
index 60d9c7c37..000000000
--- a/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-include ../tools.mk
-
-# Test that -A warnings makes the 'empty trait list for derive' warning go away
-OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
-
-all: foo
- test -z '$(OUT)'
-
-# This is just to make sure the above command actually succeeds
-foo:
- $(RUSTC) foo.rs -A warnings