summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile')
-rw-r--r--src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile b/src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile
new file mode 100644
index 000000000..bd7f62d5c
--- /dev/null
+++ b/src/test/run-make-fulldeps/compiler-lookup-paths-2/Makefile
@@ -0,0 +1,8 @@
+-include ../tools.mk
+
+all:
+ mkdir -p $(TMPDIR)/a $(TMPDIR)/b
+ $(RUSTC) a.rs && mv $(TMPDIR)/liba.rlib $(TMPDIR)/a
+ $(RUSTC) b.rs -L $(TMPDIR)/a && mv $(TMPDIR)/libb.rlib $(TMPDIR)/b
+ $(RUSTC) c.rs -L crate=$(TMPDIR)/b -L dependency=$(TMPDIR)/a \
+ && exit 1 || exit 0