summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/dep-info-spaces/Makefile.foo
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/dep-info-spaces/Makefile.foo
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/test/run-make-fulldeps/dep-info-spaces/Makefile.foo7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/dep-info-spaces/Makefile.foo b/src/test/run-make-fulldeps/dep-info-spaces/Makefile.foo
new file mode 100644
index 000000000..80a5d4333
--- /dev/null
+++ b/src/test/run-make-fulldeps/dep-info-spaces/Makefile.foo
@@ -0,0 +1,7 @@
+LIB := $(shell $(RUSTC) --print file-names --crate-type=lib $(TMPDIR)/lib.rs)
+
+$(TMPDIR)/$(LIB):
+ $(RUSTC) --emit link,dep-info --crate-type=lib $(TMPDIR)/lib.rs
+ touch $(TMPDIR)/done
+
+-include $(TMPDIR)/lib.d