summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/dep-info/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/dep-info/Makefile
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/dep-info/Makefile')
-rw-r--r--src/test/run-make-fulldeps/dep-info/Makefile25
1 files changed, 0 insertions, 25 deletions
diff --git a/src/test/run-make-fulldeps/dep-info/Makefile b/src/test/run-make-fulldeps/dep-info/Makefile
deleted file mode 100644
index c76f43a8e..000000000
--- a/src/test/run-make-fulldeps/dep-info/Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
-include ../tools.mk
-
-# ignore-windows
-# ignore-freebsd
-# FIXME: on windows `rustc --dep-info` produces Makefile dependency with
-# windows native paths (e.g. `c:\path\to\libfoo.a`)
-# but msys make seems to fail to recognize such paths, so test fails.
-
-all:
- cp *.rs $(TMPDIR)
- $(RUSTC) --emit dep-info,link --crate-type=lib $(TMPDIR)/lib.rs
- sleep 2
- touch $(TMPDIR)/foo.rs
- -rm -f $(TMPDIR)/done
- $(MAKE) -drf Makefile.foo
- sleep 2
- rm $(TMPDIR)/done
- pwd
- $(MAKE) -drf Makefile.foo
- rm $(TMPDIR)/done && exit 1 || exit 0
-
- # When a source file is deleted `make` should still work
- rm $(TMPDIR)/bar.rs
- cp $(TMPDIR)/lib2.rs $(TMPDIR)/lib.rs
- $(MAKE) -drf Makefile.foo