summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/error-found-staticlib-instead-crate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/error-found-staticlib-instead-crate
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/error-found-staticlib-instead-crate')
-rw-r--r--src/test/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile5
-rw-r--r--src/test/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs5
-rw-r--r--src/test/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs1
3 files changed, 11 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile b/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile
new file mode 100644
index 000000000..fef12c4da
--- /dev/null
+++ b/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile
@@ -0,0 +1,5 @@
+-include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs --crate-type staticlib
+ $(RUSTC) bar.rs 2>&1 | $(CGREP) "found staticlib"
diff --git a/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs b/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs
new file mode 100644
index 000000000..fe35f1f8e
--- /dev/null
+++ b/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs
@@ -0,0 +1,5 @@
+extern crate foo;
+
+fn main() {
+ foo::foo();
+}
diff --git a/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs b/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs
new file mode 100644
index 000000000..b76b4321d
--- /dev/null
+++ b/src/test/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs
@@ -0,0 +1 @@
+pub fn foo() {}