summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/foreign-exceptions
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/foreign-exceptions
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/foreign-exceptions')
-rw-r--r--src/test/run-make-fulldeps/foreign-exceptions/Makefile10
-rw-r--r--src/test/run-make-fulldeps/foreign-exceptions/foo.cpp60
-rw-r--r--src/test/run-make-fulldeps/foreign-exceptions/foo.rs59
3 files changed, 129 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/foreign-exceptions/Makefile b/src/test/run-make-fulldeps/foreign-exceptions/Makefile
new file mode 100644
index 000000000..7eba52f3c
--- /dev/null
+++ b/src/test/run-make-fulldeps/foreign-exceptions/Makefile
@@ -0,0 +1,10 @@
+-include ../tools.mk
+
+all: foo
+ $(call RUN,foo)
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)
diff --git a/src/test/run-make-fulldeps/foreign-exceptions/foo.cpp b/src/test/run-make-fulldeps/foreign-exceptions/foo.cpp
new file mode 100644
index 000000000..8182021a2
--- /dev/null
+++ b/src/test/run-make-fulldeps/foreign-exceptions/foo.cpp
@@ -0,0 +1,60 @@
+#include <assert.h>
+#include <stddef.h>
+#include <stdio.h>
+
+void println(const char* s) {
+ puts(s);
+ fflush(stdout);
+}
+
+struct exception {};
+struct rust_panic {};
+
+struct drop_check {
+ bool* ok;
+ ~drop_check() {
+ println("~drop_check");
+
+ if (ok)
+ *ok = true;
+ }
+};
+
+extern "C" {
+ void rust_catch_callback(void (*cb)(), bool* rust_ok);
+
+ void throw_cxx_exception() {
+ println("throwing C++ exception");
+ throw exception();
+ }
+
+ void test_cxx_exception() {
+ bool rust_ok = false;
+ try {
+ rust_catch_callback(throw_cxx_exception, &rust_ok);
+ assert(false && "unreachable");
+ } catch (exception e) {
+ println("caught C++ exception");
+ assert(rust_ok);
+ return;
+ }
+ assert(false && "did not catch thrown C++ exception");
+ }
+
+ void cxx_catch_callback(void (*cb)(), bool* cxx_ok) {
+ drop_check x;
+ x.ok = NULL;
+ try {
+ cb();
+ } catch (rust_panic e) {
+ assert(false && "shouldn't be able to catch a rust panic");
+ } catch (...) {
+ println("caught foreign exception in catch (...)");
+ // Foreign exceptions are caught by catch (...). We only set the ok
+ // flag if we successfully caught the panic. The destructor of
+ // drop_check will then set the flag to true if it is executed.
+ x.ok = cxx_ok;
+ throw;
+ }
+ }
+}
diff --git a/src/test/run-make-fulldeps/foreign-exceptions/foo.rs b/src/test/run-make-fulldeps/foreign-exceptions/foo.rs
new file mode 100644
index 000000000..dd3b7c76f
--- /dev/null
+++ b/src/test/run-make-fulldeps/foreign-exceptions/foo.rs
@@ -0,0 +1,59 @@
+// Tests that C++ exceptions can unwind through Rust code run destructors and
+// are caught by catch_unwind. Also tests that Rust panics can unwind through
+// C++ code.
+
+#![feature(c_unwind)]
+
+use std::panic::{catch_unwind, AssertUnwindSafe};
+
+struct DropCheck<'a>(&'a mut bool);
+impl<'a> Drop for DropCheck<'a> {
+ fn drop(&mut self) {
+ println!("DropCheck::drop");
+ *self.0 = true;
+ }
+}
+
+extern "C" {
+ fn test_cxx_exception();
+}
+
+extern "C-unwind" {
+ fn cxx_catch_callback(cb: extern "C-unwind" fn(), ok: *mut bool);
+}
+
+#[no_mangle]
+extern "C-unwind" fn rust_catch_callback(cb: extern "C-unwind" fn(), rust_ok: &mut bool) {
+ let _drop = DropCheck(rust_ok);
+ cb();
+ unreachable!("should have unwound instead of returned");
+}
+
+fn test_rust_panic() {
+ extern "C-unwind" fn callback() {
+ println!("throwing rust panic");
+ panic!(1234i32);
+ }
+
+ let mut dropped = false;
+ let mut cxx_ok = false;
+ let caught_unwind = catch_unwind(AssertUnwindSafe(|| {
+ let _drop = DropCheck(&mut dropped);
+ unsafe {
+ cxx_catch_callback(callback, &mut cxx_ok);
+ }
+ unreachable!("should have unwound instead of returned");
+ }));
+ println!("caught rust panic");
+ assert!(dropped);
+ assert!(caught_unwind.is_err());
+ let panic_obj = caught_unwind.unwrap_err();
+ let panic_int = *panic_obj.downcast_ref::<i32>().unwrap();
+ assert_eq!(panic_int, 1234);
+ assert!(cxx_ok);
+}
+
+fn main() {
+ unsafe { test_cxx_exception() };
+ test_rust_panic();
+}