summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/hir-tree/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/hir-tree/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/test/run-make-fulldeps/hir-tree/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/hir-tree/Makefile b/src/test/run-make-fulldeps/hir-tree/Makefile
new file mode 100644
index 000000000..3412c8ce1
--- /dev/null
+++ b/src/test/run-make-fulldeps/hir-tree/Makefile
@@ -0,0 +1,8 @@
+-include ../tools.mk
+
+# Test that hir-tree output doesn't crash and includes
+# the string constant we would expect to see.
+
+all:
+ $(RUSTC) -o $(TMPDIR)/input.hir -Z unpretty=hir-tree input.rs
+ $(CGREP) '"Hello, Rustaceans!\n"' < $(TMPDIR)/input.hir