summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/intrinsic-unreachable/Makefile')
-rw-r--r--src/test/run-make-fulldeps/intrinsic-unreachable/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile b/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
new file mode 100644
index 000000000..203772856
--- /dev/null
+++ b/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
@@ -0,0 +1,11 @@
+-include ../tools.mk
+
+# ignore-windows-msvc
+#
+# Because of Windows exception handling, the code is not necessarily any shorter.
+# https://github.com/llvm-mirror/llvm/commit/64b2297786f7fd6f5fa24cdd4db0298fbf211466
+
+all:
+ $(RUSTC) -O --emit asm exit-ret.rs
+ $(RUSTC) -O --emit asm exit-unreachable.rs
+ test `wc -l < $(TMPDIR)/exit-unreachable.s` -lt `wc -l < $(TMPDIR)/exit-ret.s`