summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/longjmp-across-rust
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/longjmp-across-rust
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/longjmp-across-rust')
-rw-r--r--src/test/run-make-fulldeps/longjmp-across-rust/Makefile5
-rw-r--r--src/test/run-make-fulldeps/longjmp-across-rust/foo.c18
-rw-r--r--src/test/run-make-fulldeps/longjmp-across-rust/main.rs29
3 files changed, 52 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/longjmp-across-rust/Makefile b/src/test/run-make-fulldeps/longjmp-across-rust/Makefile
new file mode 100644
index 000000000..9d71ed8fc
--- /dev/null
+++ b/src/test/run-make-fulldeps/longjmp-across-rust/Makefile
@@ -0,0 +1,5 @@
+-include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) main.rs
+ $(call RUN,main)
diff --git a/src/test/run-make-fulldeps/longjmp-across-rust/foo.c b/src/test/run-make-fulldeps/longjmp-across-rust/foo.c
new file mode 100644
index 000000000..bd71cc4d7
--- /dev/null
+++ b/src/test/run-make-fulldeps/longjmp-across-rust/foo.c
@@ -0,0 +1,18 @@
+#include <assert.h>
+#include <setjmp.h>
+
+static jmp_buf ENV;
+
+extern void test_middle();
+
+void test_start(void(*f)()) {
+ if (setjmp(ENV) != 0)
+ return;
+ f();
+ assert(0);
+}
+
+void test_end() {
+ longjmp(ENV, 1);
+ assert(0);
+}
diff --git a/src/test/run-make-fulldeps/longjmp-across-rust/main.rs b/src/test/run-make-fulldeps/longjmp-across-rust/main.rs
new file mode 100644
index 000000000..cc1d5b126
--- /dev/null
+++ b/src/test/run-make-fulldeps/longjmp-across-rust/main.rs
@@ -0,0 +1,29 @@
+#[link(name = "foo", kind = "static")]
+extern "C" {
+ fn test_start(f: extern "C" fn());
+ fn test_end();
+}
+
+fn main() {
+ unsafe {
+ test_start(test_middle);
+ }
+}
+
+struct A;
+
+impl Drop for A {
+ fn drop(&mut self) {}
+}
+
+extern "C" fn test_middle() {
+ let _a = A;
+ foo();
+}
+
+fn foo() {
+ let _a = A;
+ unsafe {
+ test_end();
+ }
+}