summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/lto-readonly-lib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/lto-readonly-lib/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/lto-readonly-lib/Makefile')
-rw-r--r--src/test/run-make-fulldeps/lto-readonly-lib/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/lto-readonly-lib/Makefile b/src/test/run-make-fulldeps/lto-readonly-lib/Makefile
new file mode 100644
index 000000000..0afbbc345
--- /dev/null
+++ b/src/test/run-make-fulldeps/lto-readonly-lib/Makefile
@@ -0,0 +1,12 @@
+-include ../tools.mk
+
+all:
+ $(RUSTC) lib.rs
+
+ # the compiler needs to copy and modify the rlib file when performing
+ # LTO, so we should ensure that it can cope with the original rlib
+ # being read-only.
+ chmod 444 $(TMPDIR)/*.rlib
+
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)