summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/output-filename-overwrites-input
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/output-filename-overwrites-input
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/output-filename-overwrites-input')
-rw-r--r--src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile13
-rw-r--r--src/test/run-make-fulldeps/output-filename-overwrites-input/bar.rs1
-rw-r--r--src/test/run-make-fulldeps/output-filename-overwrites-input/foo.rs1
3 files changed, 15 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile b/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile
new file mode 100644
index 000000000..6377038b7
--- /dev/null
+++ b/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile
@@ -0,0 +1,13 @@
+-include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/foo
+ $(RUSTC) $(TMPDIR)/foo -o $(TMPDIR)/foo 2>&1 \
+ | $(CGREP) -e "the input file \".*foo\" would be overwritten by the generated executable"
+ cp bar.rs $(TMPDIR)/bar.rlib
+ $(RUSTC) $(TMPDIR)/bar.rlib -o $(TMPDIR)/bar.rlib 2>&1 \
+ | $(CGREP) -e "the input file \".*bar.rlib\" would be overwritten by the generated executable"
+ $(RUSTC) foo.rs 2>&1 && $(RUSTC) -Z ls $(TMPDIR)/foo 2>&1
+ cp foo.rs $(TMPDIR)/foo.rs
+ $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo.rs 2>&1 \
+ | $(CGREP) -e "the input file \".*foo.rs\" would be overwritten by the generated executable"
diff --git a/src/test/run-make-fulldeps/output-filename-overwrites-input/bar.rs b/src/test/run-make-fulldeps/output-filename-overwrites-input/bar.rs
new file mode 100644
index 000000000..83be6e807
--- /dev/null
+++ b/src/test/run-make-fulldeps/output-filename-overwrites-input/bar.rs
@@ -0,0 +1 @@
+#![crate_type = "lib"]
diff --git a/src/test/run-make-fulldeps/output-filename-overwrites-input/foo.rs b/src/test/run-make-fulldeps/output-filename-overwrites-input/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/src/test/run-make-fulldeps/output-filename-overwrites-input/foo.rs
@@ -0,0 +1 @@
+fn main() {}