summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/override-aliased-flags
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/override-aliased-flags
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/override-aliased-flags')
-rw-r--r--src/test/run-make-fulldeps/override-aliased-flags/Makefile22
-rw-r--r--src/test/run-make-fulldeps/override-aliased-flags/main.rs1
2 files changed, 23 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/override-aliased-flags/Makefile b/src/test/run-make-fulldeps/override-aliased-flags/Makefile
new file mode 100644
index 000000000..bea610eeb
--- /dev/null
+++ b/src/test/run-make-fulldeps/override-aliased-flags/Makefile
@@ -0,0 +1,22 @@
+-include ../tools.mk
+
+# FIXME: it would be good to check that it's actually the rightmost flags
+# that are used when multiple flags are specified, but I can't think of a
+# reliable way to check this.
+
+all:
+ # Test that `-O` and `-C opt-level` can be specified multiple times.
+ # The rightmost flag will be used over any previous flags.
+ $(RUSTC) -O -O main.rs
+ $(RUSTC) -O -C opt-level=0 main.rs
+ $(RUSTC) -C opt-level=0 -O main.rs
+ $(RUSTC) -C opt-level=0 -C opt-level=2 main.rs
+ $(RUSTC) -C opt-level=2 -C opt-level=0 main.rs
+
+ # Test that `-g` and `-C debuginfo` can be specified multiple times.
+ # The rightmost flag will be used over any previous flags.
+ $(RUSTC) -g -g main.rs
+ $(RUSTC) -g -C debuginfo=0 main.rs
+ $(RUSTC) -C debuginfo=0 -g main.rs
+ $(RUSTC) -C debuginfo=0 -C debuginfo=2 main.rs
+ $(RUSTC) -C debuginfo=2 -C debuginfo=0 main.rs
diff --git a/src/test/run-make-fulldeps/override-aliased-flags/main.rs b/src/test/run-make-fulldeps/override-aliased-flags/main.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/src/test/run-make-fulldeps/override-aliased-flags/main.rs
@@ -0,0 +1 @@
+fn main() {}